i'm using awesome-cv template in latex. After opening it in pdf, it has a4 format. I've changed it to a5, letterpaper but in vain. I always have to zoom use button to see the full resume. But I want my resume to be shown in full page not by zooming all the time.

  • 1
    You can set your viewer to do that. If the option is fitwidth, is won't work even if the paper size changes.
    – Johannes_B
    Mar 29 '18 at 12:17
  • IIRC,hyperref has an option to select the PDF view mode, however, this might only work with Adobe Acrobat Reader.
    – Martin Scharrer
    Mar 29 '18 at 12:48
  • afaik, foxit reads that info, too.
    – thymaro
    Mar 29 '18 at 12:59

You can set this with hypersetup in your preamble. I don't understand exactly what you want to do, but take the following snippet and adapt at will:

  % PDF meta information
    pdftitle={My Duckument Title},
    pdfauthor={My Name},
    pdfsubject={A duckingly Interesting Subject},
  % Viewport settings
  % Further bells and whistles (settings pertaining to the looks and workings of the displayed PDF)
    linktocpage=true, % make page number, not text, be link on TOC, LOF and LOT
    pdffitwindow, % resize document window to fit document size
    colorlinks, % Link colors in the document
    urlcolor =#0000ff,
    breaklinks=true, % lets links in the document break across lines
    pagebackref=true, % backreference by page number

The keys are for the most part self-explanatory imho. The rest are in the hyperref manual. Best is to just search for them there and read up on what they stand for, then use the ones that fit your bit. They are in section 3.3 onwards. For instance, pdfstartview=FitH will open the PDF and set the zoom level of the viewport (your PDF viewer of choice) to the page width of the PDF displayed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.