0

I am trying to write the definition of the Fourier Series in MikTex. However, on the Integral bounds the Greek letters to not show up.

\theoremstyle{definition}
\begin{definition}{}
\label{FourierSeriesDef}

The Fourier series of a function $f(x)$ is given by

\begin{equation} \label{eq:FourierSeries}
 f(x) = \frac{1}{2}a_0 + \sum_{n=1}^{\infty} a_ncos(nx) + \sum_{n=1}^{\infty} b_nsin(nx),
\end{equation}

where

$$
a_0 = \frac{1}{\pi}\int_{-\pi}^{\pi} f(x) dx 
$$

\end{definition}

and the output is

Output of above

closed as unclear what you're asking by Henri Menke, Mico, Phelype Oleinik, Stefan Pinnow, TeXnician Mar 30 '18 at 6:53

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Cannot reproduce (minimal code, screenshot) – Henri Menke Mar 30 '18 at 0:39
  • Ah yes. I have done the same as you. I checked my latex class file and I noticed that I changed the math font to "EB Garamond". Changing it back to default or something like "Arno Pro" solved the issue. Do you know why this happens with EB Garamond. Is there a way to fix this issue? – salad salad Mar 30 '18 at 0:44
  • 1
    Still cannot reproduce (minimal code, screenshot). It's impossible to say without minimal code from your side. – Henri Menke Mar 30 '18 at 0:49
  • 1
    Welcome! If you are using unicode-math, then you cannot properly set the maths font to EB Garamond as it isn't one. However, I'd expect more spectacular failures in that case. If you are using ebgaramond-maths, please scrutinise the console output and/or log file, and read the manual. This package only supports limited maths and ought not be used in documents requiring full mathematical support. (However, the console/log does tell you how to work around the limitations, if you really insist. I wouldn't recommend that, but it is your document and not mine, after all.) – cfr Mar 30 '18 at 1:04
  • However, looking at @HenriMenke's code, I guess ebgaramond-maths isn't involved, if that example doesn't demonstrate the problem. (And I don't think pi would be affected anyway, for independently reasons.) – cfr Mar 30 '18 at 1:10
1

In case you are using unicode-math, the following setup works fine for me with the latest version of EB Garamond downloaded from https://bitbucket.org/georgd/eb-garamond/downloads/

\documentclass{article}
\usepackage{amsmath}
\usepackage{unicode-math}
\setmathfont{Latin Modern Math}
\setmathfont[range=up,Numbers=Lining]{EBGaramond12-Regular.otf}
\setmathfont[range=it]{EBGaramond12-Italic.otf}
\setmathfont[range={}]{Latin Modern Math}

\begin{document}

\[
a_0 = \frac{1}{\pi}\int_{-\pi}^{\pi} f(x) dx 
\]

\end{document}

enter image description here

  • 1
    +1. It might be a good idea to add the option Scale=MatchLowercase to the second and third \setmathfont instructions. – Mico Mar 30 '18 at 2:50
  • @Mico Trying to use a text font for maths will look like garbage anyway, so it doesn't really matter. But thanks for the suggestion. – Henri Menke Mar 30 '18 at 3:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.