0

I am using \documentclass[journal]{IEEEtran}, which has a 2-column form.

My figure code is as follows:

\begin{figure*}[!t]
\centering
\subfloat[]{
    \includegraphics[width=.315\linewidth]{fig1.eps}
    \label{fig1}
}\hfill
\subfloat[]{
    \includegraphics[width=.315\linewidth]{fig2.eps}
    \label{fig2}
}\hfill
\subfloat[]{
    \includegraphics[width=.315\linewidth]{fig3.eps}
    \label{fig3}
}
\caption{blah-blah-blah.}

On the one hand, there is no problem when I use \begin{figure}[!t]. However, on the other hand, when I use \begin{figure!}[!t], the figure is always shown in the next page. I do not know why it happens. Is there a way that the figure is located as the same as \begin{figure}[!t]?

ps) The figure should appear across both columns. Hence, I cannot help using *.

  • 1
    figure* always comes the page after the position of the environment in the source, so simply move it earlier in the file. Note you have removed thep option which means that the figure should go to the end of the document if it is large (slightly compensating by adding the ! option, but that should only be used as a last resort in special situations) – David Carlisle Mar 31 '18 at 17:28
  • 1
  • It might be possible to automate the process, but it won't be easy. The hard part will be putting it into the aux file. – John Kormylo Apr 1 '18 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.