0

I'm trying to add the skype logo to my CV using moderncv and fontawesome package. I'm running with XeLaTeX, but even with LuaLaTex doesn't work. This is my code and my output. I checked on fontawesome.com and the Unicode used is right.

\documentclass[11pt,a4paper]{moderncv}

% moderncv themes
%\moderncvtheme[blue]{casual}                 % optional argument are 'blue' (default), 'orange', 'red', 'green', 'grey' and 'roman' (for roman fonts, instead of sans serif fonts)
\moderncvtheme[blue]{classic}                % idem

\usepackage{fontawesome}
\newcommand\faSkype{{\FA\symbol{"F17E}}}

\usepackage[T1]{fontenc}
% character encoding
\usepackage[utf8x]{inputenc}                   % replace by the encoding you are using
\usepackage[english]{babel}

% adjust the page margins
\usepackage[scale=0.8]{geometry}
\recomputelengths                             % required when changes are made to page layout lengths

\fancyfoot{} % clear all footer fields
\fancyfoot[LE,RO]{\thepage}           

\firstname{XXXX}
\familyname{\\ \\XXXX}
\title{Curriculum Vitae}               % optional, remove the line if not wanted
\address{XXXXX}{XXXXXX}    % optional, remove the line if not wanted
\mobile{XXXXXXX}                    % optional, remove the line if not wanted
%\phone{xxxxxx}                      % optional, remove the line if not wanted
%\fax{xxxxxx}                          % optional, remove the line if not wanted
\email{XXXXXX}                      % optional, remove the line if not wanted
\extrainfo{\linkedinsocialsymbol \faSkype XXXXXX}

output

Someone has any ideas?

1

You should never load inputenc or fontenc with XeLaTeX or LuaLaTeX. And \faSkype is already defined by the package. The following document works for me with LuaLaTeX.

\documentclass{article}
\usepackage{fontawesome}

\begin{document}
\faSkype
\end{document}

For reasons I don't understand, XeLaTeX sometimes has problems finding fonts in the texmf tree unless you specify the filename, so if for some reason you must use XeLaTeX and not LuaLaTeX, you can load the package code manually:

\documentclass{article}
\usepackage{fontspec}
\newfontfamily\FA{FontAwesome.otf}
\makeatletter
\newcommand*{\faicon}[1]{%
  {\csname faicon@#1\endcsname}}
\input{fontawesomesymbols-generic.tex}
\input{fontawesomesymbols-xeluatex.tex}
\makeatother

\begin{document}
\faSkype
\end{document}

output of code

| improve this answer | |
  • Both solutions don't work for me. With XeLaTeX I don't find fontawesomesymbols-generic.tex and with LuaLaTex I have an error where I put \faSkype (Undefined control sequence. \faSkype). Probably because I don't defined the command explicitly. Maybe the problem is with modernCV? (I have to use the symbol outside of Document). – Giacomo Rosaspina Apr 1 '18 at 0:01
  • @TheZone Do the minimal documents in my answer not work? (Apart from modernCV)? You didn't post compilable code with moderncv but my quick test with it worked. Maybe you have an old version of fontawesome. Mine is 2016/05/15 v4.6.3.1 (TL 2017). – Alan Munn Apr 1 '18 at 0:07
  • No, I tried now (with article). Same errors of my code. How can I see the version? It is possible, they are several years that I don't use latex (2015). – Giacomo Rosaspina Apr 1 '18 at 0:10
  • @TheZone Add \listfiles to the first line of the test document and see what version of fontawesome you have. – Alan Munn Apr 1 '18 at 0:11
  • 1
    Regarding the necessity to use file name in XeTeX, it's mentioned in the fontspec documentation (see Section 1.2 of v2.6g). I submitted a Pull Request to make fontawesome compatible with XeLaTeX a while ago, but no response from the maintainer as of now. – yudai-nkt Apr 1 '18 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.