2

I'm writing an annotated bibliography that has to be in the MLA format (so no indentation first line of the citation, every line after that has to be indented once) but the annote tag automatically adds its own indentation, is there any way to remove the indentation or force it to not indent?

Here are the contents of my bibliography.bib file:

@article{sheldonrichman,
    title = {Ancient History: U.S. Conduct in the Middle East Since World
    War II and the Folly of Intervention},
    author = {Sheldon L. Richman},
    url = {https://www.cato.org/publications/policy-analysis/ancient-history-us-conduct-middle-east-world-war-ii-folly-intervention},
    year = {1991},
    month = {august},
    organization = {CATO},
    urldate = {2018-03-27},
    annote = {Here is a test annotation},
}

And here is a MWE:

\documentclass[11pt,letterpaper]{article}
\usepackage[american]{babel}
\usepackage{hyperref}
\usepackage{csquotes}
\usepackage{ifpdf}
\usepackage{mla}
\usepackage[style=mla,backend=biber]{biblatex}
\usepackage{setspace}
\doublespace
\setbool{bbx@annotation}{true}
\renewcommand{\section}[2]{}%
\bibliography{bibliography.bib}


\begin{document}
\begin{mla}{Pavel}{Fyodorovich}{class}{professor}{\today}{title}
    \nocite{*}
    \printbibliography
\end{mla}
\end{document}

enter image description here

EDIT: Ok, it seems to be that this problem is caused by the hanging indent, however, whenever I increase the hanging indent, the indent of the annotation also increases

0
3

This is caused by the fact that the annotation is put into a quotation environment. It's not hard to change.

In this example I also fixed a couple of other things. There is already an option in biblatex-mla to print the annotations, so you don't need to use the \setboolean{} command. I've also moved the loading of hyperref to the end. It should generally be loaded last.

If you want the annotation to align with the hanging indent of the bibliography entries, then remove the negative \hspace in the redefinition.

I should also note that doing annotations this way (i.e. in the .bib file) is very memory intensive, and not really recommended if you have lots of them and/or they are quite large. Since this looks like a class assignment format, it should be fine for this purpose, but I would make a separate .bib file just for this document rather than add large annotations to your main .bib file (if you have one.)

\begin{filecontents}{\jobname.bib}
@article{sheldonrichman,
    title = {Ancient History: U.S. Conduct in the Middle East Since World
    War II and the Folly of Intervention},
    author = {Sheldon L. Richman},
    url = {https://www.cato.org/publications/policy-analysis/ancient-history-us-conduct-middle-east-world-war-ii-folly-intervention},
    year = {1991},
    month = {august},
    organization = {CATO},
    urldate = {2018-03-27},
    annote = {Here is a test annotation},
}
\end{filecontents}
\documentclass[11pt,letterpaper]{article}
\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage{ifpdf}
\usepackage{mla}
\usepackage[style=mla,backend=biber,annotation=true]{biblatex}
\usepackage{setspace}
\doublespace
\usepackage{hyperref}

\renewbibmacro{finentry}{%
  \finentry%
  \iffieldundef{annotation}%
    {}%
    {\ifbool{bbx@annotation}%
      {\par
       \hspace{-\bibhang}% remove to line up with bibhang 
       \printfield{annotation}%
       }%
      {}}%
}
\renewcommand{\section}[2]{}%
\bibliography{\jobname.bib}


\begin{document}
\begin{mla}{Pavel}{Fyodorovich}{class}{professor}{\today}{title}
    \nocite{*}
\printbibliography
    \end{mla}
\end{document}

output of code

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.