1

I am using a template from my university for my thesis. It was initially in German. I changed it completely to English. The Bibliography had the title set to 'Literaturverzeichnis', I changed the language settings in the Preamble, and it now says 'bibliography', but when I cite my references in the body of the document, it still uses German - like XYZ u.a instead of XYZ et al, or uses German labels - Bericht etc instead of report. I cannot find the setting. Any help would be appreciated. Thank you. I have attached the code snippet and picture of output. As seen, it uses German 'und' instead of English 'and'. I have also included a code snippet from the Preamble which i think is relevant to the setting. I have tried permutations such as removing the German or changing the order, but to no avail.

\cite{energiewende2017} state that Germany must reduce its emissions by 95\% by the middle of this century. Gradual phaseout of almost all nuclear and coal fired power plants is also to take place in the next few years. Of the world's three biggest Carbon Dioxide emitters, China and India are fully committed to transitioning to low-emission sources of energy to tend to the energy needs of their billion-plus people. 

enter image description here

\usepackage[german, USenglish]{babel} %Überschriften werden von LaTeX in der korrekten Sprache erzeugt  

\usepackage[ansinew]{inputenc}  %Ermöglicht Eingabe von Umlauten

\usepackage{babelbib}           % um Bibtex mit deutschen Styles zu verwenden
  • 4
    Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – Stefan Pinnow Apr 2 '18 at 17:04
  • In particular, please tell us which bibliography style you employ. – Mico Apr 2 '18 at 18:15
  • By the way, unless the editing software you employ is prehistoric, there should be no justification or reason for employing the input encoding ansinew. Assuming your editor is less than 5 years old, try utf8 as the input encoding. – Mico Apr 2 '18 at 18:19
  • @Mico, thank you for your reply. I am a newbie to LaTex, that ansinew was in the Template, which I have minimally changed, and only so expressly where needed. – Anupam Apr 3 '18 at 10:58
  • 1
    \bibliographystyle{dinatles} Is this what you meant by bibliography style? – Anupam Apr 3 '18 at 11:03
0

The OP has stated in a comment that he/she uses a bibliography style called dinatles and has made the file dinatles.bst available online.

Assuming one needs to keep using this bibliographic style file and merely wishes change the language-specific settings from German to English, I suggest one proceed as follows:

  • Make a copy of dinatles.bst and call the copy, say, engdinatles.bst. (You are obviously free to choose another name.)

  • Open engdinatles.bst in a text editor. The program you use to edit your tex files will do fine.

  • Go to line 109 of the file and change all German-language strings to equivalent English-language strings. E.g.,

    FUNCTION {push.bd}        { "vol." }
    FUNCTION {push.diplom}    { "Master's Thesis" }
    FUNCTION {push.disser}    { "Doctoral Thesis" }
    FUNCTION {push.forschung} { "Technical Report" }
    FUNCTION {push.hrsg}      { "Ed." }
    FUNCTION {push.in}        { "In:" }
    FUNCTION {push.isbn}      { "ISBN" }
    FUNCTION {push.issn}      { "ISSN" }
    FUNCTION {push.kap}       { "chap." }
    FUNCTION {push.nr}        { "nr." }
    FUNCTION {push.sn}        { "pages" }
    FUNCTION {push.s}         { "pp." }
    FUNCTION {push.siehe}     { "see" }
    FUNCTION {push.ua}        { "et~al." }
    FUNCTION {push.und}       { "and" }
    FUNCTION {push.url.name}  { "URL" }
    FUNCTION {push.veranst}   { "Event" }
    FUNCTION {push.von}       { "by" }
    FUNCTION {push.zugriff}   { "Accessed on" }
    

    Happily, the author of dinatles.bst showed sufficient foresight to centralize all language-specific settings!

  • Save the file engdinatles.bst either in the directory where the main tex file is located or in a directory that's searched by BibTeX. If the latter option is chosen, be sure to also update the filename database of your TeX distribution suitably.

  • In the main tex file, change the instruction \bibliographystyle{dinatles} to \bibliographystyle{engdinatles} and perform a full recompile cycle -- LaTeX, BibTeX, and LaTeX twice more -- to fully update all items.

  • You should keep loading the natbib citation management package, but you probably no longer need load the babelbib package.

Happy BibTeXing!


A full MWE:

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@article{aa,
  author = "Anne A. Author",
  title  = "Initial Thoughts",
  journal= "Circularity Today",
  year   = 3001,
  volume = 1,
  number = 2,
  pages  = "3-4",
}
@book{ab,
  author = "Anne A. Author and Brenda B. Buthor",
  title  = "Further Thoughts",
  address= "New York",
  publisher="Wiley",
  year   = 3002,
  pages  = "45",
}
@misc{abc,
  Author = "Anne A. Author and Brenda B. Buthor and Carla C. Cuthor",
  title  = "Final Thoughts",
  year   = 3003,
}
\end{filecontents}

\documentclass{article}
\usepackage[round]{natbib}
\bibliographystyle{engdinatles}

\begin{document}
\citet{aa}, \citet{ab}, \citet{abc}

\citep{aa}, \citep{ab}, \citep{abc}
\bibliography{mybib}
\end{document}
  • 1
    Thank you so very much, @Mico. I had been trying to figure this out for the last 4 months. Finally, I decided to post this online. Your help is highly appreciated. – Anupam Apr 3 '18 at 14:22
  • @Anupam - You're most welcome! – Mico Apr 3 '18 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.