1

I have been trawling the internet all day to try and find a way to get the referencing on TeXworks to work.

Every time I run Biber on TeXworks, I now get this error message:

BibTeX subsystem: C:\Users\lcold\AppData\Local\Temp\Nl6GHw4kOm\PowerRuleReferences.bib_15576.utf8, line 2, syntax error: found "author", expected ","

My bib file looks like this:

@online{Dawkins2003 ,
author = {Dawkins, Paul} ,
title = {The Definition of the Derivative} ,
year = {2003} ,
url= {http://tutorial.math.lamar.edu/Classes/CalcI/DefnOfDerivative.aspx} ,
note = {accessed on 03 Apr 2018}
}

Thanks in advance.

closed as unclear what you're asking by moewe, Stefan Pinnow, Andrew Swann, Bobyandbob, CarLaTeX Apr 16 '18 at 7:00

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    The entry you have posted works fine despite the slightly weird convention of placing a space before the comma. The error message makes me think you have forgotten a comma after the @<type>{<entrykey> block. Can you try and find out which entry causes the error? – moewe Apr 3 '18 at 14:53
  • Your thoughts are probably not mistaken, as that is the key info in the error message ;). Also, kindly consider adding a comma after the 'note' line. In case you want to add more info to this entry, you won't have to worry about the comma, which might give you nasty, hard to trace errors. Furthermore: reference managers like jabref, mendeley or citavi don't make mistakes like this. Consider using them :) – thymaro Apr 4 '18 at 6:53
  • Any news here? Can you try and isolate which entry causes the problem? The entry shown should be fine and worked in my tests, so it must be something else. – moewe Apr 6 '18 at 6:58
  • Any news here? As mentioned in my last comment, the entry you have shown us actually works. So we can't really help you further details being absent. I'll vote to close your question as unclear what you are asking in due time if no clarifications are made. – moewe Apr 12 '18 at 18:42
  • I'm voting to close this question as unclear as the problem is not visible in the little code that is shown in the question. The question has not been updated in almost two weeks and the OP was last seen when asking the question. – moewe Apr 16 '18 at 5:51