4

I have downloaded a CV template from here, which uses altacv.cls. When I try to compile main.tex using XeLaTeX it gives following error followed by many others:

Undefined control sequence. \makecvheader

If someone can have look at the template, I would be thankful of him.

UPDATE: I have downloaded the complete project from Github and tried running the sample.tex file but finding the same error at line 89: Undefined control sequence. \makecvheader. I am Providing a snapshot and the sample.log file enter image description here

  • 1
    github.com/johannesbottcher/creativeCv is of course a template that might be better for you. No restrictions there ;-) – Johannes_B Apr 17 '18 at 8:39
  • 2
    @pkj I am not mistaken. That file does not put any limitations on formatting for you. You can decide and design as you want. – Johannes_B Apr 18 '18 at 5:36
  • 3
    I downloaded the files as ZIP, decompressed it and ran XeLaTeX. No error. – egreg Apr 30 '18 at 9:55
  • 3
    @pkj Please, add the log file. – egreg Apr 30 '18 at 10:33
  • 2
    The line with the error message. Read LaTeX for complete novices to learn more about reading the log file. – Johannes_B May 2 '18 at 7:35
0
+50

The log file shows that the used distribution is outdated. With a decently recent LaTeX installation, the template will work just fine.

I recommend to read LaTeX for complete novices (free ebook) to learn some LaTeX basics, including reading the log-file.

| improve this answer | |
1

You should know that this model is developed in several files in a working folder, the code you have tried to compile only contains the part of code that can be seen as example (sample.tex) that requires other files such as the altacv class which is not a standard class of latex (but is included locally in the working folder) . Here is the complete folder that you can download and compile without problems GitHub Complete project template.

I suggest that you always look for the complete project of the models since they are not developed under the strict philosophy of open source, in which you must be able to compile the document from a single code, some models intentionally seek to hide or entangle the code. And other times it's to avoid having too long a code, judge under your own experiences.

UPDATE: To simplify I erased the files that are not necesary to compile sample.tex but enfatizing the necessary files...

enter image description here

I get no errors

enter image description here

| improve this answer | |
  • hello @leon, thanks for the suggestion. I have downloaded the project and tried running the sample.tex file but the same error at line 89: Undefined control sequence. \makecvheader any other suggestions? Is it working for you? – pkj Apr 4 '18 at 8:21
  • Is the whole project sitting in the same directory? If it is, it should be running: the command it's barfing on is defined in the altacv class. – Paul Stanley Apr 4 '18 at 12:18
  • Sorry for not providing any update, I was travelling and not accessible to my desktop. I could not run the sample file. I am providing a snapshot: drive.google.com/file/d/1fUGGcxo13ptzyTyvGGcsWUBWjzZwvEAu/… – pkj Apr 16 '18 at 11:23
  • hi @leon, I have put bounty on this question, in case if you want to try again. Sorry but your answer did not solved my problem – pkj Apr 30 '18 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.