I am trying to use the excellent and well-maintained template/framework here for my phd thesis. https://github.com/holgern/TUB_PhDThesisTemplate since this meets all the requirements of my university.

The supplied makefile uses pdflatex/biblatex combo and works fine at the command line straightaway. However, thesis writing being a large project, I wish the familiar tool latexmk that is integrated into my editor. This helps me to perform continuous compilation and get error/warning feedback -- essentially, running with the -pvc options and with -shell-escape enabled.

However, latexmk fails to compile the project. It complains that the .bbl file is not found. The main/root source file is thesis.tex and the latexmk error message is

thesis.bbl not found!

The source code correctly sets up a valid bib file:


The supplied makefile has no problems in compiling this project.

Suspecting that there might be a bug in the software, I tried using the latest latexmk v4.55d (not available from CTAN yet), downloading it straight from the author's website, but the problem persists.

I wonder what is going on? Can anyone please help?

latexmkrc configutration

One of the community members commented below that they were able to run the project. I suspect then that something must be wrong in my project latexmkrc config, which I am posting

@cus_dep_list = (@cus_dep_list, "glo-abr gls-abr 0 makenomenclature");
sub makenomenclature {
   system("makeindex $_[0].glo-abr -s nomencl.ist -o $_[0].gls-abr"); }
@generated_exts = (@generated_exts, 'glo-abr');

push @file_not_found, '^Package .* No file `([^\\\']*)\\\'';

  • 1
    .bbl file has the name of the main file and different extension (.bbl) and this is the correct way to look for it. (So, "latexmk is looking for the wrong .bbl file." is wrong.)
    – koleygr
    Apr 3, 2018 at 17:29
  • @koleygr, thank you for pointing this out. I have now changed the title and content of this question to reflect that latexmk has troubles compiling this Apr 3, 2018 at 17:30
  • 1
    I just got the template from GitHub and compiled it with latexmk there were no problems with that. A .bbl was produced and Biber ran as intended. So there must be something more to it on your side...
    – moewe
    Apr 3, 2018 at 17:47
  • 2
    @krishna The message about the bbl file not being found is probably not from latexmk, since latexmk doesn't have any error messages ending not found!, with an exclamation symbol. (I've just searched latexmk for that string.) So something else is going on. It would help to post the output from the run of latexmk, or at least the lines around the message. A detailed reading of the output can often show what the problem is. Apr 3, 2018 at 21:05
  • 1
    @JohnCollins, I think this is a problem with my editor plugin vimtex that fails to pass the option bibtex in its default configuration. The problem was solved when I included this option. Thank you for your helpful attempt at solving the issue. Apr 4, 2018 at 15:08

1 Answer 1


I can now confirm that the problem was not with latexmk, but rather with an interface to it provided by the vimtex plugin for the text editor vim.

As per the documentation of vimtex, the call to latexmk should automatically escape the shell and run bibtex/biber as necessary. However, it fails to do so (perhaps a bug in vimtex).

I passed this to the relevant vimtex dictionary in my vimrc

let g:vimtex_compiler_latexmk = {
            \ 'options' : [
            \   '-shell-escape',
            \   '-bibtex',
            \ ],

the issue disappeared.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .