37

I am using the abstract package, but want to remove the title and associated horizontal spacing. Is there an easy way to do this?

(Be aware: this may be a complete newby question, as I have only recently started to use LaTex. Please be kind!)

% !TEX TS-program = pdflatex
% !TEX encoding = UTF-8 Unicode
\documentclass[10pt,twocolumn]{article}

\usepackage[utf8]{inputenc} % set input encoding (not needed with XeLaTeX)

%%% PAGE DIMENSIONS
\usepackage{geometry} % to change the page dimensions
\geometry{a4paper} % or letterpaper (US) or a5paper or....
\geometry{margin=1in} % for example, change the margins to 2 inches all round
\addtolength{\topmargin}{-10mm}

%%% PACKAGES
\usepackage{abstract}

%%% HEADERS & FOOTERS
\usepackage{fancyhdr} % This should be set AFTER setting up the page geometry
\pagestyle{fancy} % options: empty , plain , fancy
\renewcommand{\headrulewidth}{0pt} % customise the layout...
\lhead{}\chead{}\rhead{}
\lfoot{}\cfoot{\thepage}\rfoot{}

%%% SECTION TITLE APPEARANCE
\usepackage{sectsty}
\allsectionsfont{\mdseries\upshape 
        \sectionrule{15pt}{0pt}{-5pt}{1pt} }

\title{Title Title Title}
\author{Alistair Collins, Company}
\date{} % Activate to display a given date or no date (if empty), otherwise the current date is printed 

\begin{document}
\twocolumn[
\maketitle

\begin{onecolabstract}
One Column Abstract - it is the Abstract title that I wish to remove.\\
\end{onecolabstract}
]

\section{Section Title}
\textit{Italic text as first paragraph\\\\
}
Main text

\end{document}
0

2 Answers 2

37

The simplest way is

\usepackage{abstract}
\renewcommand{\abstractname}{}    % clear the title
\renewcommand{\absnamepos}{empty} % originally center

The title is stored in \abstractname, so we clear it; but abstract puts the title between \begin{center} and \end{center}, but actually center is stored in the macro \absnamepos; so we abuse LaTeX features and place the (empty) title in the (inexistent) empty environment so the result is that nothing will be printed and no excess space will be set.

4
  • with \usepackage[english]{babel} the abstract title does not disappear. Is there a workaround? Jan 20, 2020 at 22:37
  • 1
    @JoãoBravo Do \addto\captionsenglish{\renewcommand{\abstractname}{}} instead of just \renewcommand{\abstractname}{}.
    – egreg
    Jan 20, 2020 at 22:39
  • 1
    From the accepted answer on tex.stackexchange.com/questions/38334/… I would assume adding abstract=off to the options of \documentclass should work just fine. Can someone verify?
    – Egor Hans
    Apr 15, 2020 at 7:19
  • @EgorHans That. An work if the class supports such an option, which article doesn’t.
    – egreg
    Apr 15, 2020 at 7:34
45
\renewcommand{\abstractname}{\vspace{-\baselineskip}}

Slightly more economical than the proposed solution (no need for abstract package).

1
  • 13
    Works, but needs to be set after \begin{document}
    – Felix
    Feb 19, 2017 at 2:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .