1

When I using the \bm package, all the letters are overprinting like below.

I could not find the problem.

enter image description here

  • Provide an example that compiles, please. Welcome to the site. – Steven B. Segletes Apr 4 '18 at 20:14
  • That is bm's last resort "poor man's bold" which it does if there are no bold fonts available. What font are you using? Is there a bold font? – David Carlisle Apr 4 '18 at 20:20
3

This document reproduces your issue:

\documentclass{article}
\usepackage{mathptmx}
\usepackage{bm}

\begin{document}

$\hat{\bm{R}}$

\end{document}

You essentially cannot use bm with mathptmx.

Solution: use newtx:

\documentclass{article}
\usepackage{newtxtext,newtxmath}
\usepackage{bm}

\begin{document}

$\hat{\bm{R}}$

\end{document}

enter image description here

| improve this answer | |
  • Thank you! 1. I don't use \usepackage{mathptmx}. so I am not sure it is the reason. 2. when I add \usepackage{newtxtext,newtxmath} An error appear: Option clash for package textcomp. \DeclareRobustCommand Too many math alphabets used in version normal. \begin{document} – Yanan Apr 5 '18 at 21:15
0

In the template, there are three fonts could be choose:

1.`times' : Times font with math support.

2.`fourier': Utopia Font with Fourier Math font (Font has to be installed) It's a free font.

3.customfont': Usecustomfont' option in the document class and load the package in the preamble.tex

  1. default or leave empty: `Latin Modern' font will be loaded. If I use "times" the problem appears,

but If I use "fourier" and "Latin Modern" the problem solved. Maybe because I don't have the bold fonts for "times" and I don't know which bold fonts corresponding to "times" and how to add it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.