I updated LyX to 2.3.0-1, and found that LyX was displaying all the "-" characters in Math Mode as "\lyxminus". No such problem occurs when entering outside of Math Mode. LyX also seems to have no problem compiling to TeX, and the PDF output looks normal.

I removed and re-installed LyX, and this issue was still there.

Does anyone have any ideas on what might be going on? I am using Linux Mint 18.2 Sonya.

Note: I previously saw this question ask about the same thing, but the author appears to have deleted their post: https://tex.stackexchange.com/questions/424291/lyx-shows-lyxminus-instead-of-simple-minus-after-updating-to-2-3-0

  • I have the same problem in Linux Mint 18.3, maybe it is connected with 2.3.0 upgrade. I also see othe changes. – gorn Apr 16 '18 at 16:49
  • @gorn I updated to 2.3.0 on my Macbook Pro (running El Capitan) and have no issues with "\lyxminus". Could this be a Linux Mint only issue? – Ron Yang Apr 17 '18 at 16:57
  • Update: I compiled the latest LyX from source and the lyxminus issue is gone. So that's a potential fix. – Ron Yang Apr 24 '18 at 1:31
  • @RonYang that's good news! Note that you should be using the 2.3.x branch (this is what will turn into 2.3.1), and not the master branch (which is considered unstable and LyX 2.3.0 is incompatible with documents created with it). – scottkosty Apr 24 '18 at 5:25

I had the same problem on Debian. Solved it by:

sudo apt-get install fonts-lyx

I presume it works on Ubuntu, Mint and other Debian derivatives.

  • 2
    It precisely answers how to solve the problem on Mint. Why would it be a comment? Just because it's a one-liner doesn't mean it has to be a comment. – Satish Bysany May 12 '18 at 9:14
  • Thank you! Solved my case here in Mint! – linhares Jan 4 at 6:20

I have tried item 2 in the following. http://www.int.otaru-uc.ac.jp/lyx-howto/setup/japanize Unfortunately it is in Japanese. I briefly explain in English here.

Download  ftp://ftp.lyx.org/pub/lyx/contrib/latex-xft-fonts-0.1.tar.gz or  ftp://ftp.lyx.org/pub/lyx/contrib/latex-xft-fonts-0.1.zip and unzip it into $HOME/.fonts, then "fc-cache -fv" in terminal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.