2

I get blank space and no diagrams with the following code working in Texmaker on Windows. The mp file has been created. I have run pdflatex command. The log file gives the version as pdfTeX, Version 3.14159265-2.6-1.40.18 (MiKTeX 2.9.6500 64-bit) (preloaded format=pdflatex 2017.11.7) Any help would be much appreciated:)

     \documentclass{article}
     \usepackage{feynmp-auto}
     \begin{document}
     \begin{fmffile}{simple_labels}
     \begin{fmfgraph*}(40,25)
     \fmfleft{i1,i2}
     \fmfright{o1,o2}
     \fmflabel{$e^-$}{i1}
     \fmflabel{$e^+$}{i2}
     \fmflabel{$e^+,\mu^+$}{o1}
     \fmflabel{$e^-,\mu^-$}{o2}
     \fmflabel{$i\sqrt{\alpha}$}{v1}
     \fmflabel{$i\sqrt{\alpha}$}{v2}
     \fmf{fermion}{i1,v1,i2}
     \fmf{fermion}{o1,v2,o2}
     \fmf{photon,label=$\gamma,,Z^0$}{v1,v2}
     \end{fmfgraph*}
     \end{fmffile}
     \end{document}
  • 1
    Unfortunately, the automatic feature of feynmp-auto mo longer works because Metapost has been withdrawn from the list of programs allowed to be called in the testricted shell escape, so one needs to activate -shell-escape for the automatic call. – egreg Apr 8 '18 at 7:38
1

I could make it work by adding the force option and after compiling twice with pdflatex -shell-escape.

 \documentclass{article}
 \usepackage[force]{feynmp-auto} %<-added force
 \begin{document}
 \begin{fmffile}{simple_labels}
 \begin{fmfgraph*}(40,25)
 \fmfleft{i1,i2}
 \fmfright{o1,o2}
 \fmflabel{$e^-$}{i1}
 \fmflabel{$e^+$}{i2}
 \fmflabel{$e^+,\mu^+$}{o1}
 \fmflabel{$e^-,\mu^-$}{o2}
 \fmflabel{$i\sqrt{\alpha}$}{v1}
 \fmflabel{$i\sqrt{\alpha}$}{v2}
 \fmf{fermion}{i1,v1,i2}
 \fmf{fermion}{o1,v2,o2}
 \fmf{photon,label=$\gamma,,Z^0$}{v1,v2}
 \end{fmfgraph*}
 \end{fmffile}
 \end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.