4

why the following mwe doesn't work, if i uncomment line \end{frame}?

\documentclass[xcolor={dvipsnames,handout,svgnames,table}]{beamer}
\usepackage[utf8]{inputenc}

\begin{document}
\begin{frame}[fragile]{Test uporabe paketa "xcolor"}
\begin{verbatim}
    \documentclass[xcolor={dvipsnames,handout,svgnames,table}]{beamer}
    \usepackage[utf8]{inputenc}

    \begin{document}
    \begin{frame}[fragile]{Test uporabe paketa "xcolor"}
        \begin{center}
    \begin{tabular}{>{\columncolor{DarkMagenta}\color{white}}c % svgnames
                    >{\columncolor{Apricot}}c}                 % dvipsnames
    aaa & bbb   \\
    ccc & ddd   \\
    \end{tabular}
        \end{center}
%    \end{frame}      % <---
    \end{document}
\end{verbatim}
\end{frame}
\end{document}

i obtain error:

Runaway argument?
    \documentclass[xcolor={dvipsnames,handout,svgnames,table}]{b
! File ended while scaning use of \@xverbatim

i use recent beamer.

log file (first and last few lines from 1411)

This is pdfTeX, Version 3.14159265-2.6-1.40.19 (MiKTeX 2.9.6650 64-bit) (preloaded format=pdflatex 2018.4.7)  8 APR 2018 22:39
entering extended mode
**C:/Users/Zarko/Downloads/LaTeX-SE/beamer/beamer-xcolor.tex
(C:/Users/Zarko/Downloads/LaTeX-SE/beamer/beamer-xcolor.tex
LaTeX2e <2017-04-15>
Babel <3.18> and hyphenation patterns for 21 language(s) loaded.
("C:\Program Files\MiKTeX 2.9\tex\latex\beamer\beamer.cls"
Document Class: beamer 2018/02/20 v3.50 A class for typesetting presentations
("C:\Program Files\MiKTeX 2.9\tex\latex\beamer\beamerbasemodes.sty"
("C:\Program Files\MiKTeX 2.9\tex\latex\etoolbox\etoolbox.sty"
Package: etoolbox 2018/02/11 v2.5e e-TeX tools for LaTeX (JAW)
\etb@tempcnta=\count79
)
Package atveryend Info: Executing hook `AtEndAfterFileList' on input line 21.
Package rerunfilecheck Info: File `beamer-xcolor.out' has not changed.
(rerunfilecheck)             Checksum: D41D8CD98F00B204E9800998ECF8427E;0.
! You can't use `\end' in internal vertical mode.
\enddocument ...cumenthook \deadcycles \z@ \@@end 

l.21     \end{document}

? 

! LaTeX Error: \begin{beamer@frameslide} on input line 20 ended by \end{documen
t}.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.21     \end{document}

? 
! Missing } inserted.
<inserted text> 
                }
l.21     \end{document}

? 

! LaTeX Error: Something's wrong--perhaps a missing \item.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.22     \end{verbatim}

? 

! LaTeX Error: \begin{document} ended by \end{verbatim}.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.22     \end{verbatim}

? 
! Extra \endgroup.
<recently read> \endgroup 

l.22     \end{verbatim}

? 
! Emergency stop.
<recently read> \endgroup 

l.22     \end{verbatim}

End of file on the terminal!


Here is how much of TeX's memory you used:
 17140 strings out of 494605
 319476 string characters out of 3168337
 399027 words of memory out of 3000000
 20120 multiletter control sequences out of 15000+200000
 5020 words of font info for 19 fonts, out of 3000000 for 9000
 390 hyphenation exceptions out of 8191
 56i,5n,55p,852b,317s stack positions out of 5000i,500n,10000p,200000b,50000s
!  ==> Fatal error occurred, no output PDF file produced!
  • 1
    Works fine for me. Which beamer version do you have? – user36296 Apr 8 '18 at 20:31
  • @samcarter, i use 3.50. interestingly the same mwe was work year ago ... – Zarko Apr 8 '18 at 20:33
  • 1
    It's also working for me, with or without commenting the \end{frame} with beamer v3.48 pdflatex and miktex – BambOo Apr 8 '18 at 20:33
  • 1
    add \listfiles and then just show the file list from the end of the log. – David Carlisle Apr 8 '18 at 20:44
  • 1
    Also, any non-empty character in the specific line solves the problem (before or after the command)... So, for them who didn't manage to reproduce, try to leave just an "\end{frame}" there with no additional characters... (The "arrow comment" solves the problem by its own) – koleygr Apr 8 '18 at 21:19
1

This problem no longer exist in beamer version 3.51 or later.

Where possible, you should update your TeX distribution to install the current release. If this is not possible, for example if you want to change only this one package or where you do not have the privileges to update the entire distribution, you will need to install the package locally. This option should be considered a last resort, since for more complex packages there may be package dependencies that will make local installation more complicated and error-prone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.