Brand new to LaTeX and the MiKTeX installation, so I'm hoping my question has an easy answer. As part of my learning process, I'm trying to use the amsmath package and it does not compile as it does when I'm not using a package. Here's my little trial code:




  f(x) = x^2

The console output seems to show styles loading, then states No file TestScript.aux. and hangs there. I tried eliminating the --clean from the preferences so that an .aux file was generated, but I still get a hang.

  • 2
    Welcome to TeX.SX! You seem to be missing \end{document}.
    – egreg
    Apr 9, 2018 at 22:02

1 Answer 1


The symptoms you describe are quite clear. The console would print

This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
LaTeX2e <2017-04-15>
Babel <3.18> and hyphenation patterns for 84 language(s) loaded.
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
For additional information on amsmath, use the `?' option.
No file TestScript.aux.

and the trailing * means that TeX is waiting for input.

A document must have a valid \end{document} tag or the LaTeX job will not end.

Depending on the front-end you use, the console output (and the log file) could be different: some of the common front-ends use -interaction=nonstopmode which aborts the job in such cases:

! Emergency stop.
<*> TestScript.tex

!  ==> Fatal error occurred, no output PDF file produced!
Transcript written on TestScript.log.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .