2

I have recently been asked to use APA referencing and want to include specific page numbers for a book reference. I know that the apacite package allows this for example by typing \cite[pp.56-58]{Author2016}. This should come out like (Author 2016, pp.56-58). In stead it comes out like (?, ?)pp.56-58]Author2016.

I am using TexMaker with bibtex and the list of references compiles fine when I don't include specific page numbers but simply fails to recognise it as a reference when I do.

What seems to be the problem?

Here's the document setup I use:

\documentclass[a4paper, 12pt]{article}
        \usepackage[hidelinks]{hyperref}                           
        \usepackage{hyperref}                                       
        \usepackage{apacite}                                    
        \usepackage[english]{babel}                             
        \usepackage[footnote,marginclue,draft,danish,silent,nomargin]{fixme}    
        \usepackage[pdftex]{graphicx}                           
        \usepackage{float}                                      
        \usepackage{gensymb}                                    
        \usepackage[strings]{underscore}                        
        \usepackage[a4paper]{geometry}
        \graphicspath{{Figure/}}                                
        \setlength\bibitemsep{1\baselineskip}

... according to \cite[pp.56-58]{Author2006}.

        \bibliographystyle{apacite}
        \newpage
        \bibliography{Bib}
        \end{document}
2
  • Have you thought about using a more modern package?
    – Johannes_B
    Apr 11, 2018 at 8:03
  • @Johannes_B There's nothing wrong with apacite. It works well and is quite up-to-date. The problem is that the for the \cite[]{} syntax you need to load the package with the natbibapa option.
    – Alan Munn
    Apr 11, 2018 at 16:19

1 Answer 1

1

The apacite package supports two forms of citation commands, "classic", and natbib. The syntax you are using for your citation is the natbib syntax, so you need to load the apacite package with the natbibapa option:

\usepackage[natbibapa]{apacite}

See the following question (or the apacite documentation) for more details:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .