1

I am currently using ShareLatex with the XeLatex compiler. I need to use the Harvard referencing style, but I want to do some customizations to the agsm-style. I was not very sure were to find this file, but found something which may be the actual version here.

I want the following to happen:

Hollis, S. R. (1997), ‘Strategic and economic factors in the hospital conversion pro-cess: A financial expert, who has advised numerous hospitals on conversions,provides an insider’s look at the process and offers advice to hospital boards con-sidering affiliation.’, Health Affairs 16 (2), 131–143.

To be changed in:

Hollis, S. R. (1997) ‘Strategic and economic factors in the hospital conversion pro-cess: A financial expert, who has advised numerous hospitals on conversions,provides an insider’s look at the process and offers advice to hospital boards con-sidering affiliation.’, Health Affairs 16(2): 131–143.

So delete the comma after the year, delete the bold volume number, delete a space and change the last comma in an ':'. Already found that I can delete the bold number, by removing embolden in the latter linked code, but how can I change the other things?

P.S. I am assuming that ShareLatex supports customized Bibliography styles. Please correct me if I'm wrong.

1

Deleting the comma after the year in the bibliographystyle is complicated, because the code for inserting the year is separate for every entry type. Instead of changing all of them, you can patch \harvardyearright in the preamble of your tex file: Add

\let\origharvardyearright\harvardyearright
\makeatletter
\renewcommand\harvardyearright{\origharvardyearright\@ifnextchar,\@gobble\empty}
\makeatother

This will skip a comma, if it is the next character after the year.

The remaining changes are inside the FUNCTION format.vol.num.pages in the bst file. Like you already wrote in the question, deleting embolden in the first line of this function makes the volume number non-bold. Near the end of this function there is

  { ",~" * pages n.dashify * }

This inserts the pages preceded by ,~. To use a colon instead, change this to

  { ":~" * pages n.dashify * }
6
  • Addition: I notice some differences between the initially usedagsm citing style and the latter linked version of it. Do you know where to find the exactly same version of it? I am using ShareLatex, but running Miktex (TexWorks) is also an option.
    – Nino
    Apr 14 '18 at 13:39
  • 1
    The easiest way to find the bibliography style file without installing TeX is searching the CTAN: It is part of the harvard package, so you can downloa it at ctan.org/tex-archive/macros/latex/contrib/harvard Apr 14 '18 at 13:47
  • Outdation of the agsm.bst file wasn't the issue unfortunately. The issue is that the in-text references are now displayed as (X and Y, 2018) instead of (X en Y 2018). So the differences are: my Dutch language isn't supported and the comma is inserted. I can't find any changes from the .bst file so it may have to do with the \harvardyearright function? (Because, with the original agsm-style the in-text references were displayed the right way)
    – Nino
    Apr 14 '18 at 14:00
  • Hm, I tested my statement that the \harvardyearright was causing this problem, but a simple test made clear that this isn't the case. What else could it be...
    – Nino
    Apr 14 '18 at 14:08
  • 1
    @Nino This looks like a separate question if it is happening independant of the \harvardyearright change. Especially it it almost impossible to answer questions like this without a MWEB (See tex.meta.stackexchange.com/questions/4407/…) Apr 14 '18 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.