2

After successfully creating a customized bibliography style, my in-text references has changed from (A & B 2018) to (A and B, 2018), while I want it to be showed as (A en B 2018), with the Dutch language package. I don't understand why it is changed, while I did not write any code to do so. And how it can be changed into 'en' instead of 'and' and how to get rid of the comma.

The library style is a changed version of the agsm-style, see this question: Customise Harvard referencing style.

MWEB:

documentclass{article}
\addbibresource{\jobname.bib}
\usepackage{filecontents}
\usepackage{natbib}
\usepackage[dutch]{babel}

\begin{filecontents}{\jobname.bib}
@article{key,
  author = {Author, A. and Writer, B.},
  year = {2001},
  title = {Title},
  volume = {1},
  journal = {Journal},
  number={2},
  pages={131--143}
}
\end{filecontents}

\let\origharvardyearright\harvardyearright
\makeatletter
\renewcommand\harvardyearright{\origharvardyearright\@ifnextchar,\@gobble\empty}
\makeatother

\begin{document}
Text...
\citep{key}

\bibliographystyle{eur}
\bibliography{\jobname.bib}

\end{document}
3
  • 3
    What's the purpose of the \addbibresource{\jobname.bib} directive? Are you using biblatex after all? – Mico Apr 14 '18 at 15:34
  • @Mico I used this MWEB example (tex.meta.stackexchange.com/questions/4407/…) to reproduce the issue. This MWEB succeeds in that matter, but maybe that line of code is redundant? – Nino Apr 14 '18 at 15:58
  • 1
    @Nino At least on my system the given MWEB fails because \addbibresource is undefined. If this does not lead to an error for you, you might load biblatex somewhere. This should be avoided if you want to use natbib. – Marcel Krüger Apr 14 '18 at 16:33
3

natbib allows to change the citation style with \setcitestyle. Especially the option aysep allows to change the characterbetween the author and year. The ans can be changed by defining \harvardand.

So you get the desired citation style by adding

\setcitestyle{aysep={}}
\newcommand\harvardand{et}

to your preamble.

3
  • This works indeed to get the citations as they were. But I am also supposed to change the ampersand into an 'en', so in this way I am unable to customize the citation style. – Nino Apr 14 '18 at 16:57
  • @Nino Sorry, I edited this now to actually answer your question. – Marcel Krüger Apr 14 '18 at 17:14
  • Thank you, you're my hero today. Feel stupid that I couldn't find this somewhere, despite reading a lot about Tex – Nino Apr 14 '18 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.