2

In fact, I want to remove the date. I saw that I have to use \date{}, but in my case nothing happens and the date is still there. Here is the code:

\documentclass[12pt,stdletter,orderfromtodate,sigleft]{newlfm}
\usepackage{blindtext, xfrac}
\setlength\parindent{1cm}
\newlfmP{dateskipbefore=50pt}
\newlfmP{sigsize=50pt}
\newlfmP{sigskipbefore=50pt}
\newlfmP{Headlinewd=0pt,Footlinewd=0pt}
\date{}
 \usepackage{etoolbox} \makeatletter \patchcmd{\@zfancyhead}{\fancy@reset} 
 {\f@nch@reset}{}{} \patchcmd{\@set@em@up}{\f@ncyolh}{\f@nch@olh}{}{} 
 \patchcmd{\@set@em@up}{\f@ncyolh}{\f@nch@olh}{}{} \patchcmd{\@set@em@up} 
 {\f@ncyorh}{\f@nch@orh}{}{} \makeatother

 \begin{document}
 \begin{newlfm}
 \blindtext
 \Blindtext

 \end{newlfm}
 \end{document}
  • I think you have to use the dateno option to remove the date in newlfm. – Nicola Talbot Apr 15 '18 at 23:51
  • The date is still there – kerdouj kardouj Apr 15 '18 at 23:54
  • Use: \documentclass[12pt,stdletter,orderfromtodate,sigleft,dateno]{newlfm} as suggested by Nicola Talbot and the date won't appear. – user94293 Apr 16 '18 at 0:12
  • @NicolaTalbot Can you add that as an answer? – Alan Munn Apr 16 '18 at 3:29
1

With the newlfm class, the date visibility is set using the dateno (no date) and dateyes (show date) options. (As far as I can tell, this is just for letters, not for the memo, fax or press release options.) You can supply dateno as a class option:

\documentclass[12pt,stdletter,orderfromtodate,sigleft,dateno]{newlfm}

or using \newlfmP:

\newlfmP{dateno}

The date is set using \dateset (not \date).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.