3

As I wanted to fill the first column before going to the next one, I was using the environment \begin{multicols*}\end{multicols*}. When I compile the following scrip I have the error: "Improper \prevdepth". But it only occurs when I use 3 or more columns. How to solve it?

Multicols version:

multicol.sty    2015/08/19 v1.8n multicolumn formatting (FMi)

Code:

\documentclass{article} 
\usepackage{multicol}% http://ctan.org/pkg/multicol
\usepackage{lipsum}% http://ctan.org/pkg/lipsum
\begin{document}
\begin{multicols*}{3}    
\lipsum[1-3]
\begin{equation}
aaaa
\end{equation}   
\end{multicols*}
\end{document}

Gifs proving it:

Reproducing error

Figure 1: Reproducing Error

Reproducing Work Around

Figure 2: Reproducing work around

8
  • I get no error when running your document Commented Apr 19, 2018 at 0:04
  • @DavidCarlisle . when pdfLatex, it shows the error ! Improper \prevdepth. I'm using Texmaker on Ubuntu 16.04. Commented Apr 19, 2018 at 0:10
  • texmaker and ubuntu are not involved, presumably you have an old version of multicol you could add \listfiles to check I tried an old version 1.8p (from texlive 2016) 1.8q (texlive 2017) and 1.9r (texlive 2018) and none of them gave an error. Commented Apr 19, 2018 at 6:39
  • I get no error either with TeXLive 2012 (multicol 2011/06/27 v1.7a)
    – user4686
    Commented Apr 19, 2018 at 8:06
  • @DavidCarlisle , I updated the question with more information Commented Apr 19, 2018 at 18:33

1 Answer 1

4

After some trial and errors, I found the solution by myself. You must leave a line break on your script between \end{equation} and \end{multicols*}

\documentclass{article} 
\usepackage{multicol}% http://ctan.org/pkg/multicol
\usepackage{lipsum}% http://ctan.org/pkg/lipsum
\begin{document}
\begin{multicols*}{4}    
\lipsum[1-3]
\begin{equation}
aaaa
\end{equation}

\end{multicols*}
\end{document}
5
  • can you communicate which multicol version is used? (just check the log file)
    – user4686
    Commented Apr 19, 2018 at 8:07
  • are you sure the problem does not involve some additional package not included in your mwe?
    – user4686
    Commented Apr 19, 2018 at 8:10
  • @VitorAbella please report the version of mutlicol you have. There should be no need to add a blank line so something is really strange and if there is a problem that can be reproduced it should get fixed! For that I need clear data. Please add \listfiles to your code above and report the result (all of what \listfiles outputs) in the question! Commented Apr 19, 2018 at 8:42
  • @FrankMittelbach I updatd the question, anything else you think I should post? Commented Apr 19, 2018 at 18:34
  • 3
    The first line would have been enough: you use a 3 year old version and the problem was long corrected (which is why nobdoy could reprodue the problem), so the right thing is to update the package. Commented Apr 20, 2018 at 6:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .