2

I have one problem with the bibliography: I need to work on TexMaker with the package inputenc applemac because my supervisor absolutely wants that I use that, but when the bibliography appears, the name of the magazins and of the books are underlined, but I don't want that. How can I erase the underline ?

This is my preamble, which my supervisor has provided. Do you see anything in there which might account for this:

\documentclass[11pt, leqno, twoside]{article}
\usepackage[french]{babel}
\usepackage[T1]{fontenc}
\usepackage[applemac]{inputenc}% Codage du fichier
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{amsthm}
\usepackage{mathrsfs}
\usepackage{euscript}
\usepackage{ulem}
\usepackage{cancel}
\usepackage{array}
\usepackage[dvipsnames]{xcolor}
\usepackage[left=2cm,right=5.5cm,top=1cm,bottom=2cm]{geometry}
\usepackage{stmaryrd}
\usepackage{tikz}
\usepackage{fancyhdr}
\usepackage{setspace}
\pagestyle{fancy}

Thanks for your answer.

  • Could you post a MWE? It's not likely that inputenc would change the formatting of the bibliography in this way. The most important question is what bibliographystyle you are using, and whether you are changing anything in your preamble. – Paul Stanley Apr 19 '18 at 16:35
  • I think it is the ulem package which is doing this. – Paul Stanley Apr 20 '18 at 8:57
  • You're right! I have deleted this package ulem, and the underline has disappeared in the bibliography! Thanks a lot! – David Feutrie Apr 20 '18 at 9:09
4

The effect you see is probably the result of loading ulem which by default changes \emph to use underlining. Try loading that package with the option normalem

\usepackage[normalem]{ulem}

Or remove it altogether if you don't need underlining.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.