I'm using LaTeX on osx via TexLive 2011 and the TextMate bundle.

Currently I'm trying to list some code in a document (using verbatim), but I get this error:

! I can't find file `pcrr7t'.

! Emergency stop.

I've googled a bit and it turns out it's a font. I've searched file via locate and found it (in /usr/local/texlive/2008basic/texmf-dist/fonts/tfm/public/pslatex), but have no clue how to tell LaTeX to look there for fonts.

Did anyone run into this before ? Any hints/ideas ?

  • 1
    All files associated with that font needs to be migrated over to your /texlive/2011 folder, and then you need to refresh your filename database. – Werner Jan 30 '12 at 6:28
  • I doubt very much that it should be necessary to migrate fonts manually. pcr is courier and part of the standard psnfss-package and it should be easy to install it with the tex live manager. – Ulrike Fischer Jan 30 '12 at 9:12
  • I've got 2 versions of texlive installed 2008 and 2011. when I use locate pcrr7t it only lists the files in the 2008 folder, but not 2011 ones (although the files are there). I went to the TeX distribution options in System Preferences and selected TextLive-2008-basic and no luck. Then added another path in TextMate TEXFONTS /usr/local/texlive/2008basic/texmf-dist/fonts/tfm/public/pslatex/ but with no luck :( Any other options/ideas ? – George Profenza Jan 30 '12 at 11:16
  • Don't try to use the 2008-files. Install the missing package(s) for 2011 with the texlive manager. I don't have texlive so I don't know the actual names of the packages. Search for things like "psnfss", "courier", "fonts" .... – Ulrike Fischer Jan 30 '12 at 13:08

I suggest you go back to the TeX panel in System prefs and switch to texlive 2011. That will make it a fixed target. TextMate is unrelated to your problem, so we can skip that part. Once you do that, try any of these commands:

$ kpsewhere pcrr7t.vf
$ kpsewhere pcrr7t.tfm

You should get the same answer with a stock 2011 texlive installation.

Make sure you're not using kpsewhere from texlive 2008 to find a texlive 2011 file! Actually, I suggest you do some clean-up also: delete the 2008 distro, and any .texmf or .texlive directories in you home folder. Additionally, you can delete ~/Library/texlive, in case you want a really fresh start.

  • Thanks Koji, I've tried the above and got the right output: kpsewhere pcrr7t.vf dhcp-185-127:~ george$ kpsewhere pcrr7t.vf /usr/local/texlive/2011/texmf-dist/fonts/vf/adobe/courier/pcrr7t.vf dhcp-185-127:~ george$ kpsewhere pcrr7t.tfm /usr/local/texlive/2011/texmf-dist/fonts/tfm/adobe/courier/pcrr7t.tfm, but still get the same error :( Haven't deleted the 2008 distro yet, will try that now – George Profenza Jan 30 '12 at 15:00
  • sorry about the delay, deleting the 2008 sorted it out :) – George Profenza Feb 2 '12 at 0:43

I had the same issue. I was missing the courier package:

sudo tlmgr install courier

solved the issue for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.