1

I'm using the natbib package with the MNRAS bibliography style, and I'm wondering how I can possibly have it so the citations within my article give one, or two authors, followed by et al rather than listing them all. I understand from reading similar questions it depends slightly on the bibliography style used.

When I was previously using the full MNRAS template this was done automatically, however when I use this bibliography style within my own template it gives multiple authors which clutters the text.

Apologies if this is a trivial question, I'm pretty novice.

Here are the lines from my file relating to the bibliography for reference:

\usepackage[longnamesfirst]{natbib}
\bibliographystyle{mnras}

\bibliography{Mendeley.bib}
  • Have you tried omitting the option longnamesfirst? – Mico Apr 20 '18 at 14:18
  • 1
    Incidentally, one should not specify the filename extension in the argument of \bibliography -- it's understood that the extension should be (has to be?) .bib. This is a limitation of BibTeX; the newer biblatex package lets you specify bibliography files with extensions other than .bib. – Mico Apr 20 '18 at 14:23
  • If I remove the longnamesfirst option the MNRAS bibliography style is no longer comparible with an article style doumnet as far as i am aware. – Eliot Frazier Apr 20 '18 at 17:16
  • I was advised to include this option as a way to actually use the MNRAS bibliography style without adopting the whole template, in this post tex.stackexchange.com/questions/427108/… – Eliot Frazier Apr 20 '18 at 17:17
  • By yourself actually I see! – Eliot Frazier Apr 20 '18 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.