I am successfully using package MinionPro for pdflatex. I would like to use it also in xelatex (the math part, actually), so that I can add opentype features to the main text font. However, I am hitting a wall here. Take this simple test file:


A run with pdflatex works perfectly. But xelatex chokes on the same thing:

(/usr/local/texlive/2011/texmf-dist/tex/latex/base/ts1cmr.fd) [1] (./test2.aux)

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 MinionPro-RegularLCDFJ.pfb
mktexpk: don't know how to create bitmap font for MinionPro-RegularLCDFJ.pfb.
mktexpk: perhaps MinionPro-RegularLCDFJ.pfb is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.

** WARNING ** Could not locate a virtual/physical font for TFM "MinionPro-Regular--lcdfj".
** WARNING ** >> This font is mapped to a physical font "MinionPro-RegularLCDFJ.pfb".
** WARNING ** >> Please check if kpathsea library can find this font: MinionPro-RegularLCDFJ.pfb
** ERROR ** Cannot proceed without .vf or "physical" font for PDF output...

Output file removed.
Error 256 (driver return code) generating output;
file test2.pdf may not be valid.
Transcript written on test2.log.

I don't quite get why xelatex would need pk fonts in the first place, but I really need help in this one.

Thanks for your time.

PS: For the record, this is a fresh (re)install of texlive on OSX plus the MinionPro package.

  • 4
    For xelatex you should try installing the minion fonts on your system + using the excellent fontspec package. This is the way to go in xelatex and lualatex.
    – pmav99
    Commented Jan 30, 2012 at 10:58
  • Indeed. But minion fonts+fontspec won't give math support for minion, which is what I am looking for here.
    – Koji
    Commented Jan 30, 2012 at 11:01
  • 2
    xelatex is trying to make pk fonts as last resort because it doesn't find a map entry (pdflatex does this too if a map entry is missing). How did you install the package and enabled the map-files? Commented Jan 30, 2012 at 11:53
  • as per instructions, and updmapped. I checked kpsewhich -progname xelatex MinionPro.map and it returns the map file. The actual path is .../texmf-MinionPro/fonts/map/dvips/MinionPro/MinionPro.map
    – Koji
    Commented Jan 30, 2012 at 12:04
  • 1
    let us continue this discussion in chat
    – Koji
    Commented Jan 30, 2012 at 13:25

1 Answer 1


Sorry: I don't seem to be able to answer in the chat and I don't have the time to find out what is wrong. So I will add some comments as answer:

Your output from the xelatex compilation shows that xdvipdfmx in texlive uses the pdftex.map. It also shows that the map-entries for the minionpro fonts are in the map. The error/pk-generation happens because xelatex doesn't find the real pfb-font (MinionPro-RegularLCDFJ.pfb) mentioned in the map entry.

If your minimal document really compiles with pdflatex and uses this MinionPro-RegularLCDFJ.pfb (you should check the end of the log-file of the pdflatex the pathes of the included fonts) this would be rather curious. I would have expected xdvipdfmx and pdflatex to use the same search pathes for type1 fonts. But it is naturally possible that the search pathes differs for some reason. It is also possible that map-entry is faulty and that xelatex fails because it is more picky than pdflatex. You could try to run the document with latex + dvips to test this (dvips is picky too).

Changing the font encoding as you did with \usepackage[T1]{fontenc} can get around the problem as it will use other fonts.

  • 3
    I'll report what I found so far. The problem is that the new MinionPro fonts that come with Acrobat Reader X already have a dotlessj character. This causes the build scripts from MinionPro to fail, giving an empty file MinionPro-RegularLCDFJ.pfb . For reasons unexplained, pdflatex would happily compile, but pickier xelatex would not, in the presence of a zero-length MinionPro-RegularLCDFJ.pfb. I have downloaded the cvs from MinionPro dev site in Berlios, and I am beginning the hand building of the package. I will report when/if successfully solved.
    – Koji
    Commented Jan 30, 2012 at 15:14
  • 3
    Definitely solved. I had to use the specific build instructions from mail-archive.com/[email protected]/msg00023.html, and delete a bogus line with a '?' from MinionPro.map, but otherwise, it works now with both pdflatex and xelatex. Kudos to @UlrikeFischer for pointing the right direction.
    – Koji
    Commented Jan 30, 2012 at 15:41
  • @Koji: So the problem was actually not related to search pathes or map entries but to a third variant: a faulty pfb. Quite interesting problem ;-). I learnt something new. Commented Jan 30, 2012 at 15:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .