1

This question already has an answer here:

So let me begin by saying that I've seen that this is a very common issue, especially with texmaker on windows, and there are a lot of solutions out there, but I've tried all the ones that I found and they either didn't work or I couldn't understand them.

My code looks something like this:

\documentclass[a4paper,10pt,twoside]{report}

\usepackage[acronym,nonumberlist]{glossaries}

\loadglsentries{acronyms}
\makeglossaries

\begin{document}

\chapter*{Symbols and Abbreviations}\label{chapter:symbols and abbreviations}
\setglossarystyle{long}
\printglossary[title=Symbols]
\setglossarystyle{long}
\printglossary[type=\acronymtype, title=Abbreviations]

A whole bunch of text from my thesis with the following abbreviations and symbols, \acrfull{nf}, \acrlong{efr}, \gls{z}.

\end{document}

In my acronyms.tex file I have the following (plus a lot more)

\newacronym{nf}{NF}{Near Focus}
\newacronym{efr}{EFR}{Extra Focal Radiation}
\newglossaryentry{z}        {name={\ensuremath{z}},     description={\tabto{1cm}[$mm$] \tabto{4cm} top surface of shutters and fs distance}}

As most people I've read about this runs without the glossaries being printed.

I've tried changing some line in the Xindy file but I found it already changed. I tried changing the commands to \makeglossaries and \printglossaries or \makenoidxglossaries and \printnoidxglossaries but nope. I tried making the makeglossaries % user command in texmaker but I get the following error when running it:

Process started

makeglossaries

: The script engine could not be found. makeglossaries: Data: scriptEngine="perl.exe"

Process exited with error(s)

I've read among other solution something about installing Perl and manually adding it to some path but I don't really know what to do specifically and I have no clue if it will actually solve the problem.

If somebody could help clear out some of this and point me in the right direction it would be of great help, I've already spent a couple of hours on this stuff. Thank you all!

marked as duplicate by Troy, Stefan Pinnow, Bobyandbob, TeXnician, Mensch May 10 '18 at 18:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    It looks like you don't have Perl installed. You could try replacing the script engine makeglossaries % with makeglossaries-lite % although installing Perl so that you can run makeglossaries instead is better. Related: MiKTeX and Perl scripts (and one Python script). The option is to add automake to the list of glossaries package options. – Nicola Talbot Apr 21 '18 at 15:37
  • Installing Perl did allow the makeglossaries command to work but now when I run pdfLatex I get a whole bunch of errors that I can't even copy and paste here for some reason. While replacing with makeglossaries-lite % gives me the error Error : could not start the command : makeglossaries-lite "test". Does that mean anything to you? ps. test is the name of my file. – Skipjack3 Apr 21 '18 at 17:04
  • I don't know why makeglossaries-lite isn't working. I don't have Windows to test it on. There's some debugging methods for glossaries described in my answer to What can interfere with glossaries to prevent printing? – Nicola Talbot Apr 21 '18 at 17:24
  • 1
    That GUI diagnostic tool you made is a life saver! Took some time but I managed to make the code work. Thanks! – Skipjack3 Apr 22 '18 at 9:39

Browse other questions tagged or ask your own question.