1

I've been trying to find the source of problem without success, It keeps coming.

I'm trying to move from writing linear to modular, since the notes are getting bigger, so I'm using the subfile package. And since this, everything went wrong with the bibliography because all the special characters of the .bib aren't shown, I keep getting the Finished with exit code 1. Whereas working linearly it didn't happen. Even though the preamble is the same for both.

The main.tex looks like this

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[activeacute,spanish]{babel} %Since I'm writing in spanish I need it!
\usepackage[T1]{fontenc} %Even using this, It didn't work
 \usepackage{subfiles} %To work modular
 \usepackage{amsmath, amsthm, amssymb, amsfonts}
 \usepackage{longtable,array,tabularx,booktabs,lscape}
 \usepackage{mathtools}
 \usepackage{fancyhdr} 
 \usepackage{vmargin} 
 \usepackage{float} 
 \usepackage{graphicx} 
 \usepackage{color} 
 \usepackage{multicol} 
 \usepackage{tcolorbox} 
 \usepackage{accents} 
 \usepackage{cancel} 
 \usepackage{lmodern}
 \usepackage{hyperref} 
 \setcounter{tocdepth}{2} %Since I just have subsections in the whole doc
%Just config of the table of contents
\hypersetup{
colorlinks=true, 
linktoc=all,     
linkcolor=magenta,  
}
%New Enviroments   
\newtheorem{Def}{{Definición}}[subsection]
\newtheorem{Lema}{{Lema}}[subsection]
\newtheorem{Obs}{{Observación}}[subsection]
\newtheorem{Prop}{{Proposición}}[subsection]
\newtheorem{Teo}{{Teorema}}[subsection]
% To work with  vmargins
\setpapersize{A4}
\setmargins{2 cm}       
{1.5cm}                        
{16 cm}                      
{23.42cm}                    
{15pt}                          
{1cm}                          
{1pt}                             
{1cm}                           
%Page Style
\pagestyle{fancy}
\lhead{\bfseries Notes }
\chead{}
\rhead{}
\lfoot{ }
\rfoot{}
\cfoot{\thepage}
\renewcommand{\headrulewidth}{0.2pt}
\renewcommand{\footrulewidth}{0.10pt}


%NEW COMMANDS
\newcommand{\norm}[1]{\left\lVert #1\right\rVert}
\newcommand{\R}{\mathbb{R}}
\newcommand{\W}{\mathbb{W}}
\newcommand{\V}{\mathbb{V}}
\newcommand{\N}{\mathbb{N}}
\newcommand{\ra}{\rightarrow}
\newcommand{\rra}{\rightrightarrows}
\newcommand{\bb}[1]{\mathbb{#1}}
\newcommand{\al}[1]{\mathcal{#1}}
\DeclarePairedDelimiter\abs{\lvert}{\rvert}%
\renewcommand{\baselinestretch}{1.5}


\begin{document}
\sffamily
\tableofcontents

\newpage
\subfile{Section1}
\subfile{Section2}
\subfile{Section3}
\subfile{Section4}
\subfile{Section5}
\subfile{Section6}


\clearpage
\bibliographystyle{unsrt}
\nocite{*}
\bibliography{./AMBib}


\end{document}

On the other hand, my .bib document looks like this:

@book{OM,
Author = {Ó Searcóid,Mícheál},
Publisher = {Springer Verlag London Limited},
Title = {Metric Spaces},
Year = {2007}
}

@book{PM,
Author = {Pedro J. Miana },
Publisher = {Departamento de Matemáticas, Universidad de Zaragoza   },
Title = {Curso de Análisis Funcional: Notas de Clase},
Year = {2006},
}


@book{PJHP,
Author = {Pedro Jose Herrero Piñeyro  },
Publisher = {Universidad de Murcia},
Title = {Topología de Espacios Métricos},
Year = {2010},
}

@book{Kolmorov,
Author = {A. N. Kolmogorov , S. V. Fomin },
Publisher = {Editorial Mir},
Title = {Teoria de las ecuaciones y del análisis funcional },
Year = {1975},
}

@book{Jost,
Author = {Jürgen Jost },
Publisher = {Springer-Verlag Berlin Heidelberg},
Title = {Postmodern Analysis},
Year = {2005},
}

The problem isn't with the cross-reference or so, it does its job. The thing is for example that Ó Searcóid,Mícheál is shown without all the accented letters. I know that I can change every special character, for example Jürgen to J\"{u}rgen as well as for the others, but I had no problem before (working linearly). Is there something that am I missing?

Thanks in advance.

4
  • Several things: You are not using biblatex as your tag suggests. You are using plain old BibTeX. BibTeX officially can't really deal properly with the full range of Unicode characters - I can normally get my BibTeX to work with non-ASCII chars, but the sorting will be off. Unfortunately, your example is not really an MWE/MWEB. I don't really have time at the moment, so I can't test your code since it would require me to make up quite a few things from scratch. Help us to help you with a good MWE.
    – moewe
    Apr 23 '18 at 4:58
  • ... Your input for author names is incorrect: Several authors need to separated with and not with a comma, see tex.stackexchange.com/q/36396/35864: Author = {A. N. Kolmogorov and S. V. Fomin},. I don't think you really need subfiles' \subfile here, standard \include or even \input would probably be enough already. It also greatly helps us if you can get the .blg file of your BibTeX run with more details errors and warnings. The the Finished with exit code 1. thing is only what your editor shows.
    – moewe
    Apr 23 '18 at 4:58
  • Thanks you all, at the end the problem was because there was a somehow interference with the Fourier package. I had to get rid of it to have it as it was. Dec 16 '18 at 6:22
  • Your reputation points are now high enough you are allowed to vote up helpful answer(s). Please consider to do this with the answer below. It is the way to say "Thank You" here ...
    – Mensch
    May 23 '19 at 9:23
1

In your case the best would be to use biblatex and biber instead of bibtex. Then you can write letters with accents in your bib file which will be printed too.

Please see that you have to write two or more authors like this:

@book{Kolmorov,
  Author = {A. N. Kolmogorov and S. V. Fomin },

To concatenate two or more authors use and instead of your used ,!

To call biblatex and name the used bib file (here \jobname.bib, because I used package filecontents to have bib file and TeX code together in one compiling MWE) use

\usepackage{csquotes}
\usepackage[backend=biber]{biblatex} % <================================
\addbibresource{\jobname.bib}

Please see that option backend=biber requires biber instead bibtex.

To print the bibliography in the document use \printbibliography.

Please read the documentation of biblatex (texdoc biblatex) to customize it at your needs ...

With the following MWE (I deleted all packages not relevant for this problem)

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@book{OM,
  Author = {Ó Searcóid, Mícheál},
  Publisher = {Springer Verlag London Limited},
  Title = {Metric Spaces},
  Year = {2007},
}
@book{PM,
  Author = {Pedro J. Miana },
  Publisher = {Departamento de Matemáticas, Universidad de Zaragoza   },
  Title = {Curso de Análisis Funcional: Notas de Clase},
  Year = {2006},
}
@book{PJHP,
  Author = {Pedro Jose Herrero Piñeyro  },
  Publisher = {Universidad de Murcia},
  Title = {Topología de Espacios Métricos},
  Year = {2010},
}
@book{Kolmorov,
  Author = {A. N. Kolmogorov and S. V. Fomin },
  Publisher = {Editorial Mir},
  Title = {Teoria de las ecuaciones y del análisis funcional },
  Year = {1975},
}
@book{Jost,
  Author = {Jürgen Jost },
  Publisher = {Springer-Verlag Berlin Heidelberg},
  Title = {Postmodern Analysis},
  Year = {2005},
}
\end{filecontents*}


\documentclass{article}

\usepackage[utf8]{inputenc}
\usepackage[activeacute,spanish]{babel} %Since I'm writing in spanish I need it!
\usepackage[T1]{fontenc} %Even using this, It didn't work

\usepackage{csquotes}
\usepackage[backend=biber]{biblatex} % <================================
\addbibresource{\jobname.bib}

%\usepackage{vmargin} % outdated
\usepackage[a4paper]{geometry}

\usepackage{accents} 
\usepackage{lmodern}
\usepackage{hyperref} 
\setcounter{tocdepth}{2} %Since I just have subsections in the whole doc
%Just config of the table of contents
\hypersetup{
  colorlinks=true, 
  linktoc=all,     
  linkcolor=magenta,  
}

% To work with  vmargins
%\setpapersize{A4}
%\setmargins{2 cm}       
%{1.5cm}                        
%{16 cm}                      
%{23.42cm}                    
%{15pt}                          
%{1cm}                          
%{1pt}                             
%{1cm}                           


\begin{document}
\sffamily

\nocite{*}
%\bibliographystyle{unsrt}
%\bibliography{\jobname}
\printbibliography

\end{document}

you get the following result:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.