1

I am using the glossaries package for acronyms only, and it is working really well for my document, but I have stumbled upon a problem where it hasn't worked so well.

Literally all but one of my acronyms are work as I intended them to, the one that doesn't work quite how I'd like is one that I sometimes need to use as a plural.

When I use the acronym the first time if I wanted it to be a plural this first time I am using \glspl{fec} the problem starts as the acronym already ends in an s for it's full description.

\newacronym{fec}{FEC}{Forwarding Equivalence Class}

So when it is used with \glspl{fec} it is added another "s" to the end, whereas I would have hoped it would have known to add "es" instead.

Is there a solution to this or should I just reword what I have written to not need the plural variation of the acronym.

1

To override the default plural forms you can use the shortplural key for the short plural and longplural for the long plural. These should go in the optional argument:

\newacronym
[% options to override defaults
  longplural={Forwarding Equivalence Classes}
]
{fec}{FEC}{Forwarding Equivalence Class}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.