When I compile my .tex file in TeXWorks, PDFLaTex tells me that my OS/2 table version is 0004, and therefore incompatible. Thing is, I tried generating the font (In FontForge) as OS/2 versions 0001 through 0003, but TexWorks still insists that the OS/2 version is 0004. Every time I re-generate the font, I create a new .tfm file (through the .ttf file through ttf2tfm, though I tried .pfb/.afm (with afm2tfm) and otf).

Still, it gives me the same message of

!pdfTeX error: miktex-pdftex.exe (file ./Lotrazian.ttf): unknown version of OS/2 table (0004)

FontForge insists that the OS/2 version is 3 (or 2 or 1...): Lotrazian is OS/2 Version 3!

I tried the instructions from this guide, but to no avail.

My working environment (with the font files) can be found here

I am not sure if this is a PDFTeX, FontForge, or personal issue, but I would appreciate any help I can get

Update: I opened the .ttf file in FontForge itself, and there it says it is OS/2 Version 4. I corrected it and saved the file again, but it didn't work. Looks like this is FontForge's problem

  • I haven't seen that behavior in FontForge before. Maybe it is platform-specific, or transient during a recent change. – user139954 Apr 26 '18 at 16:05
  • 1
    @RobtAll I’m raising my concerns on the issues tab of their github page, if anything works from there on I’ll close up this question – TheBigFootsDad Apr 26 '18 at 16:06

According to this comment that I missed, having "Really Use typo metric" (on the OS/2 Metrics tab), and "Weight, width, slope only" (on the OS/2 Misc. tab) will silently upgrade the OS/2 version back to version 4. Make sure to check this if you have this problem!

  • 1
    Although that's not a TeX thing, it is worth knowing. And, that's why I never saw the problem. – user139954 Apr 26 '18 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.