2

Using \multirow{2}{*}{\cite{Smith1882}} in conjunction with the cite package \usepackage{cite} results in an unwanted space. A minimal working example gives:

enter image description here

LaTeX file:

\documentclass{article}

\usepackage{cite}
\usepackage{multirow}

\begin{document}

\begin{table}[htbp]
\begin{tabular}{|l|l|l|l|}
\hline
a & b & c & \multirow{2}{*}{\cite{Smith1882}} \\
d & e & f & \\
\hline
g & h & i & \cite{Smith1882} \\
\hline
\end{tabular}
\end{table}

\bibliographystyle{siam}
\bibliography{temp}

\end{document}

BibTeX file:

@ARTICLE{Smith1882,
  author = {John Smith},
  title = {I'm {J}ohn {S}mith},
  year = {1882}
}

Removing the cite package gets rid of the problem, but obviously means I can't use the cite package.

Question: How do I resolve this problem?

I tried changing it to &\multirow{2}{*}{\cite{Smith1882}}, and I tried adding in unnecessary brackets \multirow{2}{*}{{}\cite{Smith1882}}, but these didn't work.

4

The cite package automatically inserts a space before the \cite command. This can be seen in X\cite{Smith1882}X. Apparently, the package fails to detect that the space should not be inserted in the \multirow context.

You could load cite with the noadjust option, but that will disable the feature everywhere. Alternatively, you can temporarily turn it off with

\documentclass{article}
\usepackage{cite}
\usepackage{multirow}
\begin{filecontents}{\jobname.bib}
@ARTICLE{Smith1882,
  author = {John Smith},
  title = {I'm {J}ohn {S}mith},
  year = {1882}
}
\end{filecontents}

\makeatletter
\def\citenoadjust{\let\cite@adjust\@empty}
\makeatother

\begin{document}
\begin{table}[htbp]
\begin{tabular}{|l|l|l|l|}
\hline
a & b & c & \multirow{2}{*}{\citenoadjust\cite{Smith1882}} \\
d & e & f & \\
\hline
g & h & i & \cite{Smith1882} \\
\hline
\end{tabular}
\end{table}
a\cite{Smith1882}b
\bibliographystyle{siam}
\bibliography{\jobname}
\end{document}

enter image description here

  • In fact the package also inserts space at the beginning of a paragraph, so maybe this is a more deep-rooted problem... – moewe Apr 25 '18 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.