2
\documentclass[a4paper,11pt]{article}
\usepackage{biblatex}
\usepackage[turkish]{babel}
\bibliography{dnm2.bib} 

\begin{document}
some text \cite{abc}
\printbibliography
\end{document}

i tried to change the name of bibliography from references to "Kaynakça" (Same thing in Turkish of course) but fail lots of times. Can someone help me with that?

  • 1
    Please tell us what you've tried so far. Which document class do you employ? How do you load the babel package? (Usually, running \usepackage[turkish]{babel} should change the title of the references section to Kaynaklar.) – Mico Apr 25 '18 at 19:37
  • 1
    Which bibliography style/packages do you use? – samcarter_is_at_topanswers.xyz Apr 25 '18 at 19:41
  • I used article document class. and I've seen some advice like \addto\captionsspanish{\renewcommand{\bibname}{Bibliografía}} for other languages i tried to alter for Turkish but nothing happen. – ömer koçhan Apr 25 '18 at 19:43
  • 1
    please show a small complete document that fails and the log file that you get. – David Carlisle Apr 25 '18 at 19:50
  • 1
    Since you have some responses below that seem to answer your question, please consider marking one of them as ‘Accepted’ by clicking on the tickmark below their vote count (see How do you accept an answer?). This shows which answer helped you most, and it assigns reputation points to the author of the answer (and to you!). It's part of this site's idea to identify good questions and answers through upvotes and acceptance of answers. – samcarter_is_at_topanswers.xyz Apr 29 '18 at 19:24
2

I succeeded by passing the title directly to \printbibliography:

\begin{filecontents*}{\jobname.bib}
@article{abc,
  author={A. Uthor},
  title={Title},
  journal={Journal},
  year=2018,
}
\end{filecontents*}

\documentclass[a4paper,11pt]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[turkish,shorthands=:!]{babel}
\usepackage{biblatex}

\addbibresource{\jobname.bib}
\addto\captionsturkish{\renewcommand\bibname{Kaynakça}}

\begin{document}

some text \cite{abc}

\printbibliography[title=Kaynakça]

\end{document}

enter image description here

Notes.

  1. There are several incompatibilities between babel-turkish and biblatex; for instance one has to disable the = shorthand. The language is not really supported.
  2. Probably the bib items should have a language field, so to avoid the wrong dot above the I.
  3. The filecontents environment is used just to make the example self-contained.
| improve this answer | |
  • I can find an answer from this site somehow from users every time. when i say "i must back to the MS word" someone save me from this stupid idea with knowledge. Thank you very much. – ömer koçhan Apr 25 '18 at 20:48
  • 2
    @ömerkoçhan You might contact the developers of biblatex in order to give advice for better supporting Turkish: none of them knows the language and they're welcoming helpful people. – egreg Apr 25 '18 at 20:51
  • I'd love to help them. Because helping those kinds of smart people equally means helping to myself and other people who try to write useful things. – ömer koçhan Apr 28 '18 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.