4

I am working on a particular file in TeXstudio, meanwhile I need to look through some other Tex files. I have noticed every time I compile my file, all the other open files get saved. I don't want to save any possible changes to those files, just to be sure they have remained intact. How can I turn this off?

  • 1
    In case you don't find a solution in texstudio, you can, as a workaround, use your operating system and tempoarily make the files read only . This can even be done from the texstudio menu file->fifix->Set permissions... – user36296 Apr 27 '18 at 22:48
  • 1
    Not possible at the moment, I think. It's hardcoded into the source code -- everytime you run a command (even view-pdf), fileSaveAll() is executed. This is worthy of a feature request to the devs, in my opinion. – Troy Apr 28 '18 at 0:20
  • 3
    I considered a solution with compiling via command line in TeXstudio (through a macro, for e.g.). It works (i.e., the other documents are not saved), but in order to view the result in the internal PDF viewer, you still need to run txs:///view-pdf which triggers a fileSaveall nevertheless. – Troy Apr 28 '18 at 0:26
  • @Troy, on my linux version of txs, if the internal viewer is open then it refreshes the pdf after compiling from terminal, for example. And other opened files are not saved. So, the idea is to don't click on view pdf, but simply keep it opened. – Sigur Apr 28 '18 at 0:33
  • @Sigur Oh yeah, you're right. Guess I didn't try hard enough. :p I still don't think it's a satisfactory solution, however. Regarding @samcarter's suggestion, you can right click on the file name tab and choose Set Read-only – Troy Apr 28 '18 at 0:57
1

I use Textudio 2.12.8 in Windows (spanish installation), you can configure the document as read only by right clicking on the corresponding tab and displaying the options in which set-read only is found, then it appears with a padlock; I have not checked it because I usually want the opposite function, that is, everything is saved; Another solution is to use another editor as atom for example to visualize the files, if you have 2 monitors, of course ...

enter image description here

  • The read-only method doesn't work for me: Say A.tex is the working file, and B.tex is the 'other file'. Make changes to both so they are both unsaved. Set B.tex to read-only, then compile A.tex (or just File->Save All). Unset read-only for B.tex, and it is no longer unsaved. – Troy Apr 28 '18 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.