Consider the following input:

\usepackage{babelbib} % Multilingual bibliographies
\usepackage[num,ngerman]{isodate} % Tune the output format of dates according to language
    Author = {John Charles Reynolds},
    Language = {english},
    Title = {An Introduction to {Separation} {Logic}},
    Url = {http://www.cs.cmu.edu/~jcr/copenhagen08.pdf},
    Urldate = {2014-09-23}

After compiling with the standard pdflatex-bibtex-pdflatex loop, I get the following warning in the log:

Package isodate Warning: Language english unknown to isodate.
(isodate)                Using default format on input line 22.

I get a similar message if I use american or USenglish instead of english. Somehow, I cannot believe that isodate knows nothing about English. It would really suck surprise me a lot. What does this warning tell me? Can I simply ignore it? Or is the package simply broken and it's better to switch to something else?

(Remark: This is simply a MWE. In reality, I use svmono instead of article with tons of other packages and huge multilingual bibliography.)


You didn't pass english as an option to isodate. You should load it with:


(the last language is the default).

Alternatively, you can pass the languages as options to documentclass, which feeds both isodate and babel.

| improve this answer | |
  • I don't really know svmono, but, AFAIK, options passed to documentclass are available as global options, which means that they will be available to all packages loaded later. So I'd say yes, why not. Or you can pass them all to isodate. – gusbrs Apr 27 '18 at 23:42
  • 1
    Well, you can always add the languages as options to isodate... (as long as they are know to isodate). – gusbrs Apr 27 '18 at 23:43
  • The request seems strange. You load babelbib to have multilingual bibliographies. You load isodate to have localized dates. And at the end of the day, you want the dates in a single format? Anyway, that's another issue, for which you should ask a new question, if you don't find an answer around. – gusbrs Apr 27 '18 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy