1

I switched to texlive 2018 yesterday.

My Build-Environment: Win64, Texstudio, latexmk, lualatex, biber.

I tried to compile a test document - it worked fined using my old TL-17 and the new TL-18 installation.

Today I updated the TL-18 installation (using: tlmgr update --all). Now latexmk does not work anymore - I guess it crashes. I guess, because I don't get any output and I don't know how to further debug the problem:

Calling latexmk manually (e.g. latexmk --help) reports nothing: no help, no error message is printed. latexmk delivered with TL-17 still works fine - see this screenshot:

enter image description here

4
  • it works Ok in cygwin tl2018, could be an issue with the windows build, perhaps raise on the texlive list May 2, 2018 at 18:32
  • I also experienced this TeX Live 2018 bug, which appeared with the today update.
    – user91669
    May 2, 2018 at 18:54
  • 3
    perl path/to/latexmk.pl answers so only the wrapper seems to be broken. May 2, 2018 at 19:04
  • 1
    It already has been reported to the texlive mailing list: tug.org/pipermail/tex-live/2018-May/041574.html
    – lAtExFaN
    May 2, 2018 at 20:24

1 Answer 1

1

It seems latexmk.exe finds the wrong script.

What it should look for is

texmf-dist/scripts/latexmk/latexmk.pl

However,

texmf-dist/scripts/make4ht/extensions/latexmk.lua

is found instead.

If you do not use make4ht, one workaround is to rename latexmk.lua (for example to latexmkX.lua).

Source: http://tug.org/pipermail/tex-live/2018-May/041580.html


UPDATE: The author of make4ht has renamed latexmk extension to latexmk_build in version 0.2b.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.