0

https://www.overleaf.com/read/rmzywchdhqbs

This is the link to the template. More specific I want to change the language using the package babel, but is not working well.

7
  • Do you have to use babel? Have you tried polyglossia?
    – AML
    Commented May 2, 2018 at 19:17
  • Hard to tell exactly what your issue is, but see if this link helps: tex.stackexchange.com/a/20991/121944
    – AML
    Commented May 2, 2018 at 19:33
  • @AML polyglossia is only usable with XeLaTeX and LuaLaTeX but the template loads fontenc with the T1 encoding so this will not work. Furthermore, since Javier Bezos, the maintainer of babel is Spanish, support for Spanish is most certainly more mature in babel.
    – Alan Munn
    Commented May 2, 2018 at 19:33
  • What do you mean by “not working well”?
    – egreg
    Commented May 3, 2018 at 7:53
  • @AlanMunn Well, as far as babel is concerned, I'm trying to be language agnostic. But on the other hand, I'm the maintainer of babel-spanish, too. Anyway, I'd say support for LGC languages is in general better in babel than in polyglossia (even for XeTeX and LuaTeX), thanks to the contributed language styles. Commented May 3, 2018 at 13:48

1 Answer 1

2

This is due to a clash between the babel-spanish option and the nag package. To get around this, you can either load spanish with some modifiers:

\usepackage[english,spanish.notilde.lcroman,shorthands=off]{babel}

OR alternatively, comment out the \RequirePackage[l2tabu]{nag} on the first line. (Probably inadvisable to do so...)

3
  • I mean that the problem with this templete form Overleaf, is because in the main .tex, there are two package that include the leguage spanish. for example in line 3, I have: \RequirePackage[l2tabu]{nag} and in the 167 \usepackage[utf8]{inputenc} and the last in line 183 \usepackage[spanish,english]{babel} Commented May 3, 2018 at 15:30
  • And my response fixes this; I've updated my response to make this clearer. Your project now compiles fine after I used the spanish.notilde.lcroman option.
    – imnothere
    Commented May 4, 2018 at 0:52
  • Thank you very much, Lian, these commands were very useful and solved the problem. Commented May 4, 2018 at 16:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .