1

After upgrading to TL2018, increase the paper size (a3 or a2) or orientaion to landscape does not set the text sizes. You can see it when using the layout package (a4 and landscape in this example): Wrong Text size Parameters

Can you confirm this? And where can I report this as a bug? It happens in all standard latex and koma classes and with lua/xe/pdflatex.

MWE:

\documentclass[landscape]{scrartcl}
\usepackage{layout}
\begin{document}
\layout
\end{document}  `
  • with article I see no change from previous releases, 1 page output (which looks better if you add \usepackage{graphicx} so that the pdf page size is set to the landscape orientation). With scrartcl as posted above then in 2018 you get 3 pages and the output seems wrong, so it seems like a change in scrartcl – David Carlisle May 4 '18 at 10:47
  • you get a differently worded warning from Koma's typearea.sty even without loading layout, in 2017 Package typearea Warning: Bad type area settings! and in 2018 Package typearea Warning: Very low DIV value! so the koma-script page code has certainly changed here. – David Carlisle May 4 '18 at 10:51
  • It is a documented change of typearea (see komascript.de/release3.24), the author writes there that the old behaviour were not as documented and so a bug. You probably will have to set the DIV value manually. – Ulrike Fischer May 4 '18 at 11:14
  • It's a bug in typearea.sty; report to komascript. – egreg May 4 '18 at 11:55
2

It is a change in typearea. It will no longer use settings meant for A4 paper if it detects an obviously different paper size. It will (as the documentation has claimed for a long time) then calculate the dimensions based on the fontsize.

If you want the old layout back you can do it like this:

Compile once with

\documentclass[landscape,version=3.24]{scrartcl}

This will give the old behaviour. Check in the log-file the DIV value:

 Package typearea Info: These are the values describing the layout:
 (typearea)             DIV  = 10

Use this value as option:

\documentclass[landscape,DIV=10]{scrartcl}
\usepackage{layout}
\begin{document}
\layout
\end{document} 
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.