1

I'm running MiKTeX 2.9.6650 on an Ubuntu 16.04 machine. After successfully setting it up, I wanted to install additional languages. That option used to be in the Settings, so I assumed to find it in the new miktex-console. As far as I can see, though, there is no such option: »Settings« has two tabs, »General« and »Directories«, but nothing relating to languages at all.

Am I missing something very obvious or has it just not been implemented yet? If the latter, how can I install additional languages without the console?


One year later: It seems, there still is no option to enable a language in my setup (I just tried with a fresh installation); a workaround that had been posted on github (https://github.com/MiKTeX/miktex/issues/136) does not work anymore, either. It seems, MikTeX is not an option under Linux.

1

The tabs are already there in a current miktex (I checked both in miktex next and a standard miktex)

enter image description here

But there is no "add language button" (at least not in my single user installation, perhaps it is different for a multiuser installation). One only can enable and disable existing languages. So ff you want to add really new languages you will have to change the languages.ini manually.

  • Thank you for that info. Can you point me towards how do to switch my installation over to MiKTeX Next? Checking 'Retrieve pre-release packages' in the Package Source settings does not seem to change anything, at least no upadates are reported as being available. – dariok May 4 '18 at 14:12
  • Changing to "retrieve pre-release" worked for me. If you have a multiuser installation you problem need to do in admin mode as it mostly affects binaries. – Ulrike Fischer May 4 '18 at 14:15
  • The 'Language' tab is available on my non-next system as well (2.9.6677). So maybe a normal update suffices. – moewe May 4 '18 at 14:16
  • @moewe could be, I didn't check there yet. – Ulrike Fischer May 4 '18 at 14:18
  • Well, I did a fresh install immediately before asking so I thought I should have the newest version available. That, however, does not seem to be so – MiKTeX reports version 2.9.6650. I have a single user installation so that should not be the issue. – Well, it seems I'll just have to wait, probably the mirror accessed by the updater is not synced yet. – dariok May 4 '18 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.