After updating my MikTeX distribution couple of days ago I discovered that search for words with ligatures (such as "fi" in prefix), which has worked before, fails.

Here the MWE illustrating the problem (compilation with xelatex):


As discussed here, the line \usepackage{fontspec} enables the correct behaviour.

Adding the font settings \setmainfont[...]{FutigerLTCom-Light} leads to the incorrect behaviour. Is there a bug that possibly has been introduced to the fontspec package or somewhere else in one of the latest MikTeX updates?

  • 3
    I can confirm that there is problem, not only in miktex but also in texlive 2018. It looks like a xdvipdfmx problem and I did sent a message to the texlive list. May 4, 2018 at 16:08
  • 2
    The problem has been hopefully fixed in the sources. I can't say when it will picked up by miktex. May 6, 2018 at 12:30
  • I updated my MikTeX distribution, but unfortunately I see no changes. BTW, if I use \setmainfont{Times New Roman}, everything works as expected...
    – Mik
    May 10, 2018 at 16:55
  • I have miktex next here on the PC, perhaps the newest xdvipdfmx isn't yet in the standard miktex. May 10, 2018 at 17:00
  • 4
    I'm voting to close this question as off-topic because it was solved after updating as mentioned in comments.
    – Mensch
    Nov 20, 2018 at 22:08


Browse other questions tagged .