1

I am having a bit of a problem with a paper I am working on in Sharelatex. For some reason I can not get the bibliography to sort alphabetically.

The code looks like this:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage{hyperref}
\usepackage[swedish]{babel}
\usepackage{csquotes}
\usepackage{dirtytalk}
\usepackage[backend=biber,authordate,sorting=nyt,cmsdate=both,maxcitenames=3]{biblatex-chicago}

\addbibresource{bibliography.bib}

\urlstyle{same}

\begin{document}

Text \nocite{*}

\printbibliography

\end{document}

And my bib-file looks like this:

@book{almqvist1984,
author={Solveig Almqvist},
title={Geng{\aa}ngarf{\"o}rest{\"a}llningar i svensk folktro ur genreanalytisk synpunkt},
publisher={Almqvist {\&} Wiksell international},
address={Stockholm},
year={1984},
titleaddon={(\bibstring{phdthesis})},
} 

@book{hall2013,
author={Mikael Häll},
title={Skogsrået, näcken och Djävulen: Erotiska naturväsen och demonisk sexualitet i 1600- och 1700-talens Sverige},
year={2013},
publisher={Malört},
address={Stockholm},
titleaddon={(\bibstring{phdthesis})},
}

@book{stattin1984,
author={Jochum Stattin},
title={Näcken: spelman eller gränsvakt?},
year={1992},
origdate={1984},
publisher={Carlsson},
address={Stockholm},
titleaddon={(\bibstring{phdthesis})},
}

@book{worsley1968,
author={Peter Worsley},
title={The trumpet shall sound: A study of ”cargo” cults in Melanesia},
year={1968},
publisher={Schocken Books},
address={New York},
}

For some reason the output I get sorts the bibliography in way that puts Worsley 1968 first in the list:

enter image description here

What am I doing wrong?

4
  • I don't think you are doing anything wrong. Indeed, I cannot reproduce the issue, for the entries are sorted as expected for me (with an up to date TeX Live 2018). Could you please tell us which version of biblatex you are running? You should be able to find it in your log file. (I won't be able to do much with it, but the information will likely be useful to the more knowledgeable).
    – gusbrs
    May 7, 2018 at 18:00
  • 1
    Ah, this probably might help: tex.stackexchange.com/q/361282/105447.
    – gusbrs
    May 7, 2018 at 18:11
  • It seems to be this version "Package: biblatex-chicago 2017/04/19 v 3.7 biblatex style" and "biblatex 2016/12/05 v3.7 "
    – Erik
    May 7, 2018 at 18:14
  • 1
    Also related tex.stackexchange.com/q/396126/35864
    – moewe
    May 7, 2018 at 19:13

1 Answer 1

0

It does seem, as gusbrs indicated, to be the bug/problem hinted at here: Can't sort references alphabetically

This:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage{hyperref}
\usepackage[swedish]{babel}
\usepackage{csquotes}
\usepackage{dirtytalk}
\usepackage[backend=bibtex,authordate,sorting=nyt,cmsdate=both,maxcitenames=3]{biblatex-chicago}

\addbibresource{bibliography.bib}

\urlstyle{same}

\begin{document}

Text \nocite{*}

\printbibliography

\end{document}

Now results in: enter image description here

7
  • Did the link solve the problem to you? If so, I think it is best if we mark this question as a duplicate of that one.
    – gusbrs
    May 7, 2018 at 18:26
  • Yes it dit. I do not think I am able to mark that myself though.
    – Erik
    May 7, 2018 at 18:30
  • 2
    I can do so. But I think your change to the bibtex as a "solution" is less than ideal. bibtex is regarded as a legacy backend for biblatex which does not have the full functionality granted by biber. I'd suggest you that ideally work with an up to date installation (this issue is clearly dealt with for the current version) or, if that's not possible, use moewe's answer.
    – gusbrs
    May 7, 2018 at 18:34
  • 2
    Indeed you don't have that option within ShareLaTeX. I would have to go for a local installation.
    – gusbrs
    May 7, 2018 at 18:38
  • 2
    You can try the option sortlocale=en to override the broken Swedish sorting temporarily. But then your document follows English sorting rules and not Swedish rules. With backend=bibtex you can't sort Unicode characters properly either, so both options fare equally bad in that regard.
    – moewe
    May 7, 2018 at 19:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.