I'm using the KOMAscript scrbook class together with the minitoc package. When I compile, I get the message

Usage of package minitoc together (scrbook) with a KOMA-Script class is not recommended.

Is there a replacement to minitoc? Or does it simply mean I must rather stick with the book class? Can I get the same appearance using another KOMA friendly package?

enter image description here


Seems easier than I thought:


\usepackage{etoc, blindtext}

\chapter{First Chapter}




\section{First section in first chapter}


\section{Second section in first chapter}

And this section even has subsections:


\subsection{First subsec in second sec of first chapter}


\subsection{You know how to proceed}



First I tried to find out how to do that without the etoc package, because the tocbasic package, which is part of the KOMAscript bundle, surely provides the machinery. However, with etoc it seems fairly easy.

chaptertoc picture

  • merci, the only thing missing now is the rule (see my posting). – aerioeus May 8 '18 at 13:35
  • @aerioeus Change \addsec... to \addsec*{#1\\\rule{\textwidth}{0.4pt}}}{}% – Keks Dose May 8 '18 at 14:14
  • What if I want bold for section lines (number on the left, title, page) like with the default minitoc settings? – Archange Mar 15 at 1:07
  • @Archange Sorry, I don't understand your very short description. May I recommend to ask your own question including a description what you want and a minimal working example? Feel free to take the code posted here! – Keks Dose Mar 15 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.