1

I'm new to LaTeX and recently started using TeXworks on a Linux Mint 18.3 computer. I needed to edit the preferences and to my surprise discovered that numbers are in written Arabic rather than numerals (see the two uploaded files). How can this be fixed?

Screenshot 1a

Screenshot 2a

Please see the two further screenshots - I hope they mean something to you. In addition, FYI my location is Abu Dhabi UAE, couldScreenshot 4 this could be the source of the problem?

I cannot continue right now, but will look in again tomorrow.

Screenshot 5

A few minutes ago I tried the following using the terminal, changed LC_NUMERIC to have en_US.UTF-8 as the language: Screenshot 6

This gave me:

Screenshot 7

So I then started TeXworks and looked at the Preferences, but there was no change, so I perofrmed a Restart thinking this was correct. There was still no effect.

Is it possible that I can "force" the locale settings to become "fixed" so that they cannot be altered? Please advise this frustrated novice. Thanks

  • In the General tab, what does it show for the Locale? – Nicola Talbot May 8 '18 at 16:08
  • For Locale it shows "System default (English)" does this help you to help me? If you tell me how to do it, I will upload another screenshot (if it helps). – Holosterium May 9 '18 at 12:11
  • I have just worked out how to return to edit my original question and upload an additional screenshot - I hope this helps – Holosterium May 9 '18 at 13:29
  • The measurement seems to be set as arabic, don't know if texworks grabs this set insteat of numerals? – Johannes_B May 9 '18 at 14:28
  • I think it's picking up the LC_NUMERIC setting. – Nicola Talbot May 9 '18 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.