1

I had tables with footnotes that were placed below the table using Minipage boxing, as described in the wiki. The document compiled well using an older LyX version (2.2.?, not sure). But after upgrading to version 2.3.0 the footnotes are sent to the bottom of the page and the Minipage seems to have no effect. What should I do to get the previous behavior?

Here is an example file. Here is the output.

Thank you.

2
  • The google drive links appear to be protected. – scottkosty May 11 '18 at 5:22
  • I can confirm that the PDF will look as expected with 2.3.1 (I just tested your .lyx file with the LyX version that will be developed into 2.3.1). – scottkosty May 11 '18 at 5:35
1

This will be changed back to the previous behavior in LyX 2.3.1, which should be released within the next couple of weeks. To get the old behavior back with LyX 2.3.0, you can add the following to the preamble (Document > Settings > LaTeX Preamble):

\renewcommand{\tablefootnote}{\footnote}

as noted by Paul Rubin.

2
  • This worked for 2.3.0, thank you. Will I have to remove the line from the preamble after upgrade to 2.3.1 or later versions? – FNia May 11 '18 at 5:39
  • @farshadnia yes you should – scottkosty May 11 '18 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.