15

I am on Ubuntu 8.04 and just install TeX Live with :

sudo apt-get install texlive-full.

I tried to compile my .tex file with TexMaker. I get :

  1. xcolor.sty not found
  2. titlesec.sty not found

How can I fix the problem ?

14

Make sure you have all neccesary packages installed:

You can install them with apt-get:

sudo apt-get install texlive-latex-recommended texlive-latex-extra

You can also try to use tlmgr to install missing packages for the current user (tlmgr in Debian/ubuntu runs always in user mode).

The texlive distribution provided by ubuntu is usually pretty old. You might want to consider to install a newer version manually.

| improve this answer | |
  • 1
    sudo apt-get install texlive-latex-extra indeed solves the problem. I don't see any issues now in 2015. – Wilmer E. Henao Apr 9 '15 at 20:57
  • texlive-latex-extra is only 500MB vs the 2GB of the parent texlive-full package. This answer is preferable IMHO. – meawoppl Dec 22 '15 at 19:12
  • texlive-latex-extra just helped me with a missing pgfcore.sty. – Waldir Leoncio Nov 12 '19 at 9:11
  • I think on Ubuntu 18.04, latex-xcolor doesn't exist anymore. Correct me if I am wrong. – Jason Liu Mar 2 at 23:17
  • @JasonLiu Seems like xcolor is now in texlive-latex-recommended. I'll edit this answer – someonr Mar 3 at 13:23
8

I am not entirely sure what version of texlive is on Ubuntu 8.04. Haven't the repos deprecated? I.e. your packages are very old.

I suggest you do a manual installation. See texlive 2011. It is actually not that difficult.
If you do this please remember to uninstall texlive-full, and others, using your package manager.

| improve this answer | |
0

Here I am in 2020 and I found that TeXWorks (Version 0.6.2 (Debian) [r.7ecce17, 2017-04-29 10:23 AM]) could not find the xcolor package from my TeXLive 2019 installation on Ubuntu 18.04 LTS while another IDE like TeXMaker could do it.

The fix was to bump up the path where the .sty file gets copied to (or the soft link to it anyway): /usr/local/bin, in the tab for Typesetting in the Preferences dialogue that is reached through the Edit/Preferences menu from the menu toolbar in the main window.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.