1

I would like to remove comma at the end of the phrases in the index, just before page numbers. So my question is essentially the same, as it was asked here: Is there an easy way to hide comma (,) from the end of the indexed words? But the answer was given for the case of makeindex, and I'm using xindy to sort phrases.

The minimal working example (TeXLive 2017, Windows, PL localization):

%& -translate-file=cp1250pl

\documentclass[a4paper]{article}
\usepackage{polski}

\usepackage[texindy]{imakeidx}

\makeindex[options=-L polish -C cp1250]

\begin{document}

a\index{a}

abc\index{abc|see{a}}

\printindex

\end{document}

Then, I have the following output in the index:

enter image description here

However, I would like to remove commas after the phrases, so in the index, there will be something like "a 1" and "abc zob. a".

  • 1
    Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code. It doesn't need to be long, something like \documentclass{article}\usepackage[xindy]{imakeindex}\begin{document}Test\index{test}.\end{document} as long as it demonstrates the problem. – Nicola Talbot May 12 '18 at 11:11
  • The question was changed and improved. – errenay May 15 '18 at 8:26
1

It looks, that I've found an answer. In my local folder, I've created an additional style file, named as mymakeidx.xdy, with the following content:

;; delim_0 <string>         " "
;; delim_1 <string>         " "
;; delim_2 <string>         " "

(markup-locclass-list :open " " :sep " ") 

Then I've changed one line in the main .tex file into

\makeindex[columns=1, options=-M mymakeidx -L polish -C cp1250]

to load this new file. And it works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.