Related to this xelatex question. I get Missing character: There is no π in font cmr10!. So I set the unicode font to cmu (computer modern unicode) as advised by this question for xelatex

\font\cmu=cmu10 at 10pt
\cmu π

and try again but nothing changed, it still complains Missing character: There is no π in font cmu10!. I also tried the ecrm1000 font as advised by this answer regarding xetex. The solution of downloading a different(?) computer modern unicode font is not acceptable because it requires installing the fonts into an OS font directory with root permissions, and I will only use default fonts, or fonts that can be included along side the source tex file.

  • I see nowhere in the linked question and answers a reference to cmu10. – egreg May 15 '18 at 10:58
  • probably due to ignorance, but I assumed that CMU Serif was just a latex equivalent reference to cmu10. – user8578151 May 15 '18 at 11:00

Turns out this solution will work, but you don't need to bother installing the font into your system, all you have to do is copy the cmunrm.otf file in the same directory as your source tex file and do this

\font\cmu="[cmunrm]" at 10pt
\cmu π

run xetex source.tex and now it works!

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.