6

I find that my todo notes are cropped:

cropped \todo note

This seems to be the case no matter where I put the note. I think the problem might be the fullpage package.

\documentclass[a4paper, fleqn, 12pt]{amsart}

\usepackage{fullpage}
\usepackage{amsmath}
\usepackage{mathtools}
\usepackage{amsthm, todonotes, color, amsfonts, hyperref, amssymb, tipa}
\usepackage{graphicx}
\usepackage{hyphenat}
\usepackage{arydshln}

\usepackage{subcaption}

\begin{document}

Lorem ipsum dolor sit amet,\todo{Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.} consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.

 \end{document}

enter image description here

Please help :)

The same problem arises with the following code and resolves when fullpage is removed:

 \documentclass[a4paper, fleqn, 12pt]{amsart}
 \usepackage{fullpage}
 \usepackage{todonotes}

 \begin{document}
 Lorem ipsum dolor sit amet,\todo{Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.} consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. 
 \end{document}
  • fullpage sets the margins width to be 1in by default. Use something like \usepackage[textwidth=0.75in]{todonotes} instead? – Troy May 15 '18 at 14:57
  • Nah, that didn't work, @Troy. – Shaun May 15 '18 at 16:49
  • Did you load todonotes on its own, with this option, instead of in a bundle as in your sample code? – erreka May 17 '18 at 17:51
  • Yes, @erreka; I've edited the question. – Shaun May 17 '18 at 18:04
  • Shaun, I've tried it here and Troy's suggestion works perfectly. In what sense did it not work for you? – gusbrs May 17 '18 at 18:09
4
+50

The value to change is textwidth, and the manual points out that you need to adjust \marginparwidth, so

\usepackage[textwidth=0.7in]{todonotes}

Equivalently,

\usepackage{todonotes}
\setlength\marginparwidth{0.7in}

should do the job.

  • From the documentation: "textsize=value sets the default text size of the inserted todonotes to the given value. Value is the ”name” of the used font size, eg. if the desired fontsize is \tiny use textsize=tiny. The default value is textsize=normalsize." – gusbrs May 17 '18 at 18:17
  • you're right: I messed up the name of the key while typing. thanks. – erreka May 17 '18 at 18:20
  • 1
    If so, you are essentially employing Troy's suggestion. The call to \setlenght\marginparwidth is, as far as I can tell, redundant there. – gusbrs May 17 '18 at 18:22
  • @gusbrs section 1.6.7 Reduce number of warnings of the manual recommends it. In fact, what I think the op was doing wrong was the call to todonotes. I only pointed out the right way to do it, the same as you say in your comment above. – erreka May 17 '18 at 18:30
  • Well, \setlenght\marginparwidth seems to be doing something: it works but \usepackage[textwidth=0.7in]{todonotes} does not. – Shaun May 17 '18 at 18:51
4

Do not use package fullpage. Set the margin with geometry:

\documentclass[a4paper, fleqn, 12pt]{amsart}

\usepackage[margin=2cm,rmargin=5mm,includemp]{geometry}
\usepackage{mathtools}
\usepackage{amsthm, todonotes, color}
\usepackage{showframe}

\begin{document}

    Lorem ipsum dolor sit amet,\todo{Lorem ipsum dolor sit amet, consectetur adipiscing 
    elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.} consectetur 
    adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.

\end{document}

enter image description here

The same setting as fullpage:

 \usepackage[margin=1in,marginpar=0.75in]{geometry}

or with fullpage

 \usepackage{fullpage}
 \setlength\marginparwidth{0.75in}
  • 1
    I'd rather use fullpage: I like the proportions. – Shaun May 17 '18 at 18:48
  • 2
    It is no problem to set the same margins with geometry. fullpage doesn't set the margin text width, which looks like a bug. See edited answer for values just like the one from fullpage – user2478 May 17 '18 at 18:58
  • Don't throw 1k of code to a problem you can solve with 1 line. – erreka May 17 '18 at 19:02
  • fullpage is 3kb; geometry is 42kb. – erreka May 17 '18 at 19:07
  • @erreka but fullpage is so minimal that someone could almost call it bugged. Obv it's not bugged, simply it doesn't handle the margins. – gvgramazio May 18 '18 at 8:42
2

This is actually not so much a problem of todonotes. Rather, even a simple \marginpar would get cropped, and todonotes happens to use \marginpar. To avoid the cropping, you can make \marginparwidth smaller. (IMHO fullpage should do that automatically.)

 \documentclass[a4paper, fleqn, 12pt]{amsart}
 \usepackage{fullpage}
 \usepackage{todonotes}
 \makeatletter
 \setlength\marginparwidth{\FP@margin}
 \addtolength\marginparwidth{-4mm}
 \makeatother
 \begin{document}
 Lorem ipsum dolor sit amet,\todo{Lorem ipsum dolor sit amet, consectetur
adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna
aliqua.} consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore
et dolore magna aliqua. \marginpar{xyz abc def gh }

 \end{document}
  • 1
    @erreka Yes, I said it should. It defines its own margin width, \FP@margin, but doesn't adjust marginparwidth. So ordinary \marginpars get also cropped. – user121799 May 17 '18 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.