I am writing a journal paper using Texstudio. I have the problem that using the following preamble the result of the bibliography style is the following in the text of my paper

example of how my bibliography appear in my paper

The preamble used in my paper is the following

\documentclass[preprint,12pt,authoryear]{elsarticle}
% !TeX spellcheck = en_US 
\usepackage{siunitx}
\sisetup{detect-weight, detect-display-math}
\sisetup{detect-inline-weight=math}
\sisetup{mode=text,per-mode=symbol}
\usepackage{booktabs}
\usepackage{graphicx}
\usepackage{pgfplots}
\usepackage{pdflscape}
\pgfplotsset{compat=newest}
\usetikzlibrary{plotmarks}
\usetikzlibrary{arrows.meta}
\usepgfplotslibrary{patchplots}
\newlength\fwidth
\setlength{\fwidth}{0.8\textwidth}
\pgfplotsset{plot coordinates/math parser=false}
\usepackage{overpic}
\pgfplotsset{compat=1.15}
\usepackage{float}
\usepackage{etoolbox}
\usepackage{natbib}
\usepackage{hyperref,url}
\newcounter{bibcount}
\makeatletter
\patchcmd{\@lbibitem}{\item[}{\item[\hfil\stepcounter{bibcount}{\thebibcount.}}{}{}
\setlength{\bibhang}{2\parindent}
\renewcommand\NAT@bibsetup%
[1]{\setlength{\leftmargin}{\bibhang}\setlength{\itemindent}{-\parindent}%
    \setlength{\itemsep}{\bibsep}\setlength{\parsep}{\z@}}
\makeatother
\bibliographystyle{agsm}
\usepackage{bicaption}
\usepackage{makecell}
\renewcommand\theadfont{\bfseries}
\renewcommand\theadgape{}
\usepackage[skip=1ex, labelfont=bf]{caption}
\usepackage[skip=0.333\baselineskip]{caption}
\usepackage{tabularx}
\newcolumntype{C}{>{\centering\arraybackslash}X}
\def\UrlFont{\normalfont}
\sisetup{per-mode=symbol}
\usepackage[margin=2.5cm]{geometry} 
\usepackage[skip=0.333\baselineskip]{caption}
\usepackage{amssymb,amsmath}

\journal{fuel}

\begin{document}


\section*{References}
\bibliography{bilbiography}

%% else use the following coding to input the bibitems directly in the
%% TeX file.

\end{document}

\endinput

A reviewer told me that the references should be numbered and appear in the order they appear in the text.

I don't know how fix this problem. Could anyone help me?

  • I forgot say that the references should appear numbered in the text of my paper. – Martín Torres Brunengo May 16 at 15:30
  • 1
    Just drop the authoryear option in the \documentclass directive. Also, the agsm bibliography style can only generate authoryear-type citation call-outs. You need to switch to a bibliography style that can generate numeric-style citation call-outs. Since you're using the elsarticle document class, I suggest you employ the elsarticle-num bibliography style. After changing the argument of \bibliographystyle, be sure to run a full recompile cycle: LaTeX, BibTeX, and LaTeX twice more. – Mico May 16 at 16:07
  • Incidentally, there's no need to load the natbib package explicitly, as this package is loaded automatically by the document class. Also, load the url and hyperref packages last, and be sure to load hyperref after, not before, url. – Mico May 16 at 16:12
  • BTW, nothing good is going to come from loading the caption package three separate times. – Mico May 16 at 16:14
  • Thank all for the comments! However the problem of list the bibliography according it appear on the text , did not work. In the bibliography section, it appear alphabetically. I would that it appear according the bibliography was cited in the paper. – Martín Torres Brunengo May 16 at 16:26

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.