1

I have problen with quotation marks when I used in spanish language. This is an example a I got error Package csquotes Error: ucs package not supported. \MakeOuterQuote{"}

\documentclass{report}
\usepackage[utf8x]{inputenc}
\usepackage[spanish]{babel}
\usepackage{csquotes}
\MakeOuterQuote{"}
\begin{document}
    Carl Marx advirtió: "El Capital"
\end{document}
  • 1
    Remove the x from utf8x. – Ulrike Fischer May 17 '18 at 17:35
  • But I want the text: Carl Marx advirtió: "El Capital" and removinx X from utx8 write different. – Andrey Vinajera May 17 '18 at 17:38
  • 1
    I see no difference, but in any case: remove the x, and if something is wrong then, ask a new question how to correct it. csquotes won't work with utf8x/ucs. – Ulrike Fischer May 17 '18 at 17:48
  • The example works brilliantly for me if I use \usepackage[utf8]{inputenc} instead of \usepackage[utf8x]{inputenc}, just as Ulrike suggests. Normally utf8 should be enough and utf8x should not be needed. And in fact utf8x sometimes creates more problems than it solves. Try without x and tell us what you don't like (with an example, the output you get, and the output you desired instead). – moewe May 17 '18 at 18:28
1

Using

``El Capital''

produces

enter image description here

Is this what you want?

1

Change utf8x by utf8 is a better solution than write ``El Capital'' because this produce «El Capital»that in Spanish is the recommended first level of quoting (Diccionario panhispánico de dudas.

Moreover, you yo not need csquotes for this, as spanish babel option provide the << and >> shorthands to do the same.

Note that <<...>> is a quoting environment, that unlike "..." and ``...'', it can be nested producing the right quotation marks: Spanish quillements in first level, English double quotation marks in the second, and single quotation marks in a third level, just as suggested by the RAE.

This is the same result that nesting three times a quoting environment. or use the \lquoti, \rquoti, \lquotii, \rquotii, \lquotiii and \rquotiii marks

Instead, ``...'' as well as write directly the Spanish guillemets («...», in my Linux keyboard: AltGr+Z and ALtGr+X), are not environments, they always produce the same marks, that cannot change according to the nesting level.

That you do not care of nested quotes? Ok, like me, but there are another good reason to use a true environment: You can redefine a environment to change the style of quoted text (change to italics, color, size...).

Other alternatives to <<...>> are ".... "' or "< ..."> but the second cannot be nested. Note that moreover some babel shorthands are incompatible with some packages (for instancecsquotes`)

\documentclass{report}
\usepackage[utf8]{inputenc}
\usepackage[english,spanish]{babel}
\usepackage{xcolor}
%\usepackage{csquotes}
%\MakeOuterQuote{"}
\begin{document}
\subsubsection*{Allowed quotes:}
Carl Marx advirtió: <<El Capital>>  (recommended) \par
Carl Marx advirtió: ``El Capital''  (allowed, but worse)\par
\subsubsection*{Nesting quotes: }
\begin{quoting}El 
\begin{quoting}gran 
\begin{quoting}Capital%
\end{quoting} de mi molsillo%
\end{quoting}\end{quoting}  (right way)\par
<<El ``gran `Capital' de mi bolsillo''>> (unnecesarily complicated)\par
<<El <<gran <<Capital>> de mi bolsillo>>>> (right easy way)\par
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.