This question already has an answer here:

I have a problem with the way my bibliographic references turn up in the text. I use JabRef to handle the bibliography. In my preamble, I use the option maxcitenames and mincitenames to make sure that multiple authors (more than 2) will only be cited as "Firstauthor et al." in the document itself, while all the authors are listed in the bibliography. However, I have encountered the following curious problem. Two different papers that I need to quote are both written by four different authors, the first of which is the same in both cases.

Concretely, the author "Wiklund" is the first author of both papers. What I want, is of course the first reference to appear in the text as (Wiklund et al. 2007), and the other as (Wiklund et al. 2009). But somehow, Biber (or perhaps the problem is JabRef) feels it has to cite the second author in both cases to distinguish between the two.

Here is a MWE and below is a picture of what it produces + the JABREF source of the two relevant entries. Notice that if I only reference one of these entries, everything works fine and only (Wiklund et al. 2007) or (Wiklund et al. 2009) appears. The problem is caused by the co-occurrence of these entries.

\documentclass[12]{article}

\usepackage[backend=biber, style=authoryear-comp, sortcites=false, maxcitenames=2, mincitenames=1, maxbibnames=4]{biblatex}

\addbibresource{flafla.bib}

\begin{document}

Some text\parencite{Wiklundetal2007}. Some more text \parencite{Wiklundetal2009}  

\printbibliography

\end{document}

enter image description here

@Article{Wiklundetal2009,
  author =  {Wiklund, Anna-Lena and Benzen, Kristine and Hrafnbjargarson, Gunnar Hrafn and Hróarsdóttir, Thorbjörg},
  title =   {On the distribution and illocution of V2 in Scandinavian that-clauses},
  journal = {Lingua},
  year =    {2009},
  volume =  {119},
  number =  {2},
  pages =   {1914-1938}
}

@Article{Wiklundetal2007,
  author =  {Wiklund, Anna-Lena and Hrafnbjargarson, Gunnar Hrafn and Hróarsdóttir, Thorbjörg and Bentzen, Kristine},
  title =   {Rethinking Scandinavian Verb Movement},
  journal = {Journal of Comparative Germanic Linguistics},
  year =    {2007},
  volume =  {10},
  pages =   {203-233}
}

marked as duplicate by gusbrs, Community May 17 at 20:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    You are probably looking for biblatex's option uniquelist. If you set it to uniquelist=false does it produce the desired result? – gusbrs May 17 at 19:23
  • 1
    Btw, please do not post code (the bibentries, in this case) as image. You may edit your question and add them as text, so that people can actually use them without having to type it. (To edit the block as a code block, you can select it and use the {} icon). – gusbrs May 17 at 19:25
  • 2
    Have a look at tex.stackexchange.com/q/69028/35864 for a bit of background and explanations. But gusbrs already gave the answer, you probably want uniquelist=false. – moewe May 17 at 19:35
  • BTW: style=authoryear-comp with sortcites=false may result in some citations not being compressed as normally expected with that style. This may or may not be intended. – moewe May 17 at 19:46
  • @gusbrs, thanks, that fixed the problem. I used sortcites=false since otherwise, multiple \cites were listed alphabetically rather than chronologically. Now there is no sorting at all, so I just make sure to put them chronologically myself. Is there a better way to do this? – EspenJK May 17 at 20:06

Browse other questions tagged or ask your own question.