3

I am trying to make some words in greek bold, but no matter what I try fails. I use \usepackage[english,greek]{babel} because I need both greek and english in my paper and I also use \usepackage[utf8x]{inputenc}.

Both \bf and \textbf work fine for the english words, but when I try them on the greek words (after the \selectlanguage{greek} or \textgreek commands) they do not seem to work. The text is printed just the same as without these commands. What can I do?

closed as unclear what you're asking by egreg, Troy, Mensch, moewe, Sebastiano May 21 '18 at 10:37

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    Don't let use guess which fonts your document is using, make a (small), complete example. – Ulrike Fischer May 20 '18 at 16:54
  • I use [LGR,T1]{fontenc} and {textcomp,amssymb}. I am completely new to latex, so I am not sure what else you need. The template was ready and I added only the greek language. – Thomas May 20 '18 at 17:00
  • 1
    I wrote a complete example. One that starts with \documentclass and ends with \end{document} and that we can compile to check the fonts. Regarding templates: tex.stackexchange.com/a/391022/2388 – Ulrike Fischer May 20 '18 at 17:03
3

To long for a comment. In this minimal document bold greek works fine:

\documentclass{article}
\usepackage[utf8]{inputenc} %not needed with texlive 2018 and current miktex
\usepackage[T1]{fontenc} 
\usepackage[greek,english]{babel}
\begin{document}

hallo Welt \textgreek{γεια κόσμο}

\bfseries hallo Welt \textgreek{γεια κόσμο}

\end{document}

enter image description here

If the example fails for you and you don't get bold greek, show the log-file.

If the example works for you, you will have to find out what your document is doing differently. (I wouldn't use the utf8x-option but utf8 but this shouldn't be relevant here).

  • This example works fine, but I cannot see the difference with my project. I use just the same packages (apart from utf8x, because when I change it to utf8 it causes some errors- but it definitely doesn't cause the problem). Could the addition of extra packages AFTER these specific ones cause the problem and what kind of packages could they be? – Thomas May 21 '18 at 9:29
  • You shouldn't use utf8x. If you get errors with utf8: make an example and ask how to correct them. – Ulrike Fischer May 21 '18 at 11:02
1

I just found out that the problem was caused by the package aeguill that was added later. Discarding this package, the bold greek letters appear just fine. Thank you very much for your time and effort!

Not the answer you're looking for? Browse other questions tagged or ask your own question.