Having this problem for a while now while using TexStudio: I write a paper in TeXstudio and use the "Build & View" button, no problems, code works and example view appears on the right side. However, as soon as I save my .tex-file, I can no longer watch the example view, nor will it create a .pdf. When I look into the folder, there isn't even a .pdf-file there. When clicking on the error it brings me to a pgflibraryfadings.code.tex file, giving me a red line at:

\pgfdeclarehorizontalshading{pgf@lib@fade@east}{100bp}
{color(0bp)=(pgftransparent!0); color(25bp)=(pgftransparent!0);
    color(75bp)=(pgftransparent!100); color(100bp)=(pgftransparent!100)}

Anyone got any ideas? This issue turned up out of nowhere and happens with literally every file I have.

error As you can see the only error i get is about writing on the pdf, which is not opened at the time and actually does not exist: here is a picture of the folder: folder

closed as off-topic by Troy, Phelype Oleinik, Stefan Pinnow, Andrew Swann, Bobyandbob Jul 5 at 6:40

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 5
    I suppose you viewed the pdf with the Adobe Reader? It locks the pdf to prevent overwriting – Herbert May 20 at 16:38
  • Not really, texstudio doesnt seem to be creating a pdf file at all (anymore), i usually just watch the pdf on the right halve of texstudio after "Build and View". when i look into the folder of the file, there is no pdf there. i also tried creating a new file, saving right away and then compile, still got an error even though there shouldnt have been a pdf file to begin with since all i did was save the .tex file – Morieris May 20 at 16:55
  • compile your document on the command line to check if it contains errors. – Ulrike Fischer May 20 at 17:09
  • I suspect that some other file was set up as root file and so txs compile that file instead of the new one. In Option menu you can find the root options. – Sigur May 20 at 19:09
  • 4
    I'm voting to close this question as solved in comments. – Troy Jul 5 at 2:19

Browse other questions tagged or ask your own question.